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Document Conventions

There are several conventions that are used throughout this document to indicate actions to be taken or to 
highlight important information.  The conventions are as follows:

Item
 

Meaning

View Perimeter a command name or a file that you are to select

Tools > Options a command path that you are to select – usually from the pull-down 
menus

Document Name the name of a document that is not hyperlinked

Emphasis style used when referring to important word or phrases

Hyperlink style used when you have a direct link to another document on the web

Key in entering data with the keyboard

Quote style used to indicate an external source quotation

Note: text information about a command or process that you should pay 
particular attention to

1. Numbered Steps actions that you are to perform as part of the lab activities

<D> or Data press the data button on the mouse

<R> or Reset press the reset button on the mouse

<T> or Tentative press the tentative button on the mouse
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LAB 1 - Getting Started in InRoads Survey

Lab 1.1 - Set CDOT XM Environment and Verify Resources

Section Objectives:

After completing this exercise you will know how to:

♦ Create a new design file for use with Topo collection.

♦ Verify the correct MicroStation resources are in place for topo data reduction and 
exporting.

1. From the Windows Start menu Start > All Programs > _CDOT_CADD_Information > 
V09.08.XX-XM > Select Group Environment. The CDOT Select Group 
Environment dialog will appear.

2. From the CDOT Select Group Environment dialog select xxMulti-Discipline

3. <D> the OK button.  The dialog will close and the Workspace will be set.

Note: By following these steps the correct MicroStation resources, such as the level and 
cell definitions have been defined.

4. Double-click on the InRoads Survey desktop button    or select 
Start > All Programs > Bentley> InRoads Group XM > InRoads Survey. 
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5. In the MicroStation Manager dialog go to the Workspace group section and change

♦ User: CDOT User
♦ Project: 12345
♦ Interface: CDOT

Note: In this class, the project name 12345 will be used as the 5 digit project code.This 
workspace setup will load the most current CDOT MicroStation environment.

6.  In the MicroStation Manager dialog path to the directory: 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

7. Select the file 12345SurveyTopo##Scale##.dgn from the MicroStation Manager 
dialog.

Note: The purpose of the files with “##” symbols are for creating new files with the 
correct naming convention.
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8. <D> Open the MicroStation Manager dialog will close and open the file.

Note: Be patient, MicroStation will first load the DGN file and will work as the CAD 
engine.  InRoads Survey will then load and will run on top of MicroStation.

9. Once both programs are loaded the Tip of the Day dialog may open containing a different 
tip each time the program is started.  To suppress this dialog in the future uncheck Show 
Tips on Startup.  To access the Tip of the Day dialog in the future, select 
Help > Tip of the Day.

10. <D> the Close button on the Tip of the Day dialog.

11. From the MicroStation pull-down  menu  File > Save As The Save As dialog will 
appear.

12. Path to the folder C:\Projects\12345\ROW_Survey\Working

13. Replace the ## symbols with 100 scale and 01 model.  Type in Files: 
12345SurveyTopo100Scale01.dgn

14. <D> the Save button the Save As dialog will close and MicroStation will open the file 
12345SurveyTopo100Scale01.dgn

Note: As shown at the beginning of this lab the steps for selecting the appropriate Group 
defined what MicroStation resources will be loaded.  Before proceeding in 
InRoads, the level definition files Topo.dgnlib and ROW.dgnlib need to be 
attached.
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15. From the MicroStation pull-down menu, select: Settings > Level > Manager.  The 
Level Manager dialog will appear.  Look for [Topo] and [ROW] in the Level Name.

♦ You can also use the Level Manager button from the Primary Toolbar to open the 
Level Manager dialog.

♦ If one of the DGN libraries is not loaded close MicroStation and use the Select Group 
Environment utility to select the 
xxxMulti-Discipline environment.

16. Close the Level Manager dialog.
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17. Verify that the cell library CDOT-Topo cells.cel is attached.  From the MicroStation 
pull-down menu, select Element > Cells the Cell Library dialog box will appear.

♦ You can also use the Cell Library button from the Primary Toolbar to open the Cell 
Library dialog.

18. From the Cell Library dialog select the File pull down menu and pick Topo.cel from the 
list of cell libraries.

♦ If the Topo cell library is not loaded close MicroStation and use the Select Group 
Environment utility to select the 
xxxMulti-Discipline environment.

19. Close the Cell Library dialog.

20. From the Main MicroStation pull-down menu, select File > Save Settings

Note: From this point forward, unless specifically instructed to use MicroStation 
commands, all references to the selection of buttons, tools, or menu pull-downs 
refer to the InRoads interface.

Section Summary:
♦ A new design file was created in MicroStation and InRoads Survey was started.

♦ MicroStation resources were verified prior to importing any survey data.

Lab 1.2 - Setting Project Defaults

Setting default directories and resource files provides the user with quick access to project 
folders for opening files and then saving them to the correct location.  It also ensures the correct 
CDOT InRoads resource files will be used.

Section Objectives:

♦ Open and set CODT Project Defaults.

♦ Import and export Project Default settings.



Page 12 Colorado Department of Transportation

LAB 1 - Getting Started in InRoads Survey Labs for Using InRoads Survey for Data Reduction

1. From the InRoads pull down select File > Project Defaults the Set Project Defaults dia-
log will appear.

2. <D> the Import button.  The Open dialog will appear.

3.  Path to the folder C:\Projects\12345\Project_Configuration

4. Select the file CDOT_Disciplines.reg
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5. <D> the Open button.  The Open dialog will close and default project settings are 
imported.

6. From the drop down list Configuration Name select the discipline 
CDOT ROW_Survey Discipline
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Note: The Default Directory Paths that are left blank are files that are not used by 
InRoads Survey.

7. <D> the Apply button.

Note: The settings that have been created are stored in the Windows registry on your PC. 
To share this Project Default setup with other project staff export to a Registry file 
(REG).

8. <D> the Close button on the Set Project Defaults dialog.

9. Select the Preferences tab on the Workspace bar and verify that the correct InRoads 
Project resource files are now loaded.

Section Summary:
♦ In this lab Project Defaults were imported and set using a registry file.

Lab 1.3 - Toolbars

Toolbars can be added from the pull-down menus.  All InRoads Survey toolbars can be 
customized to fit your workflow or personal preferences. Start by opening Toolbars that will be 
used in class.

Section Objectives:

♦ Open an InRoads Survey toolbar.

♦ Dock, undock, and resize toolbars.

1. From the InRoads pull-down menu select Tools > Customize. The Customize dialog will 
appear.
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2. Under the Toolbars tab check that the boxes for Locks, Survey, and View Survey 
Data are selected.  The toolbars will appear either docked or floating in the InRoads 
interface.

3. <D> the Close button. 

4. Dock, Undock, and Resize the toolbars to become comfortable with the procedure.  
Notice how you cannot dock the toolbars into the MicroStation environment.



Page 16 Colorado Department of Transportation

LAB 1 - Getting Started in InRoads Survey Labs for Using InRoads Survey for Data Reduction

5. Move your cursor over a button in a docked or undocked toolbar and hover. A Tool Tip 
will appear at the lower right of your cursor.  

♦ This feature is controlled in the Customize dialog box Show Tool Tips check box 
and is turned on by default.

Section Summary:
♦ In this lab toolbars were opened and docked into the InRoads interface.

Lab 1.4 - InRoads Survey Options - Overview

The Survey Options dialog contains added preferences specific to the Survey commands.  
The file loaded from the Project Defaults dialog is CDOT-Survey_Preferences.fxp

Section Objectives:

♦ Create an Audit Trail file.

♦ Setup up the Survey Options General tab.

1. From the InRoads pull-down menu, select Tools > Survey Options the 
Survey Options dialog will appear.

Note: The first setting to look at will be the Audit Trail.  The Audit Trail is useful for 
keeping track of any changes made to the Survey Fieldbook or Survey Feature 
Table.
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2. Under the General tab move your cursor to the Fieldbook Audit Trail File Name: field 

and <D>.  The Browse  button will become active.

3. <D> the Browse  button.  The Save dialog will appear.  Verify the correct directory, 
C:\Projects\12345\ROW_Survey\InRoads \Field_Books

4. Key-in “UserInitials”_FieldBookEdits

5. <D> the Save button.  The Save dialog will close.

6. Check the box Add/Edit Audit Trail in the File Options section.  All edits made will 
now be saved to the RBM_FieldBookEdits.log file.

Note: The Log file is a text file that can be opened and printed from Notepad.
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7. <D> on the Units tab. Take a minute to review the settings and verify they are the same as 
the dialog below.

8. <D> on and review the tabs Symbology, Corrections, and Observation Standard 
Deviation.

9. From the Survey Options dialog <D> the Save then OK button.

Note: The setup will not need to be done each time InRoads Survey is started.  To 
demonstrate that, Exit out of the program.

10. From the InRoads Survey pull-down menu, select File > Exit.  Nothing should need to 
be saved.  If InRoads asks to save a file choose No.

11. From the MicroStation pull-down menu, select File > Save Settings. This will ensure 
when the file is opened in the next lab the cell library will be attached and view settings 
saved.

12. From the MicroStation pull-down menu, select File > Exit.  By default MicroStation is 
always saving the design file so there is no reason to save the file.  This will exit 
completely out of MicroStation.

Section Summary:
♦ In this lab an Audit Trail file was created to keep track of future edits to the fieldbook 

file.

♦ In this lab Survey Options were verified prior to importing any raw survey data.
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Lab 2.1 - Opening Survey Data

Start by viewing a survey fieldbook that is already complete.

Section Objectives: 

♦ Open a MicroStation file.

♦ Open an existing Survey Fieldbook.

1. Double-click on the InRoads Survey desktop button    or select 
Start > All Programs > Bentley > InRoads Group XM > InRoads Survey. 

2. In the MicroStation Manager dialog go to the Workspace group section and change

♦ User: CDOT User
♦ Project: 12345
♦ Interface: CDOT

3. From the Working folder select the file 
C:\Projects\12345\ROW_Survey\Working\12345SurveyTopo100Scale01.dgn

4. <D> the OK button or double click the filename.
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5. From the InRoads Survey pull-down File > Open.  The Open dialog will appear.

6. From the Open dialog change the Files of Type to Survey Data (*.fwd).

Note: Notice how the directory folder changed to Field_Books when the Files of type 
changed.  This is one of the benefits of setting up the Project Defaults for each 
discipline.

7. Select the file 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\12345SURVFieldbook01.fwd

8. <D> the Open then Cancel buttons.

Note: InRoads is Memory based, not Disk based. The file(s) in the Workspace pane are 
copies from the disk drive and reside in the computer’s memory. Any changes to 
these data files (or creation of new data files) requires them to be saved back to the 
disk drive.
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Lab 2.2 - CAD vs. Fieldbook Viewing

Take a look at the InRoads Survey interface; notice the two files loaded in the Survey tab.  The 
file with the red box around the button is the active file.  Any commands that are selected will 
use the active file.

Section Objectives:

♦ View a fieldbook in the Survey Information Window.

♦ View the survey data in the MicroStation view.

♦ Fit the Survey data in a MicroStation view.

♦ Use the shortcut menus in the Interface.

1. Use your cursor and <D> on the default Survey fieldbook Book 1. 

2. <R> on Book 1 and from the fly out menu select Set Active. Notice how the red box 
moved to Book 1 this indicates the active fieldbook.

3. <R> on 12345SURVFieldbook01 and from the fly out menu select Set Active and make 
that the active fieldbook book again.

4. Fit the survey data to the view from the pull-down Survey > Fit View the entire fieldbook 
will be displayed in the active view.

5. Use the MicroStation viewing tools to zoom to the west end of the project.

Windowed Area
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6. Investigate the viewing options of the Survey data.  From the pull-down menu toggle the 
display on and off for:

♦ Survey > View Survey Data > Planimetrics
♦ Survey > View Survey Data > Symbols
♦ Survey > View Survey Data > Names
♦ Survey > View Survey Data > Codes
♦ Survey > View Survey Data > Elevations
♦ Survey > View Survey Data > Errors
♦ Survey > View Survey Data > Notes
♦ Survey > View Survey Data > Networks.
♦ Ignore Write Survey Data to Graphics for now.

                        

 Symbols                                           Names

                       

                                   Codes                                                Elevations

7. Also practice viewing different combinations of data using the View Survey toolbar.  
Ignore Write Survey Data to Graphics for now.

Note: The survey data that is viewed is dynamic.  Nothing is actually in the MicroStation 
design file.  Control of the size of the dynamic text for Point Name, Elevation, and 
Code etc. from the Survey Options Text Symbology tab.
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8. From the pull down menu Survey > Find Point in View the Find Point in View dialog 
will appear.

9. Type in the field Point Name: 3686 Radius: 50

10. <D> the Apply button.  The MicroStation view is updated and zoomed into point number 
3686.

11. <D> the Close button in the Find Point in View dialog.

12. Toggle on View Planimetrics, View Symbols, View Codes and View Elevations.

13. From the pull-down menu, select Tools > Survey Options the Survey Options dialog 
will appear.
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14. Select the Symbology tab.

15. In the Survey Options dialog select the Text Point Elevations

16. In the Precision drop down list select .123.  Then select the Save button.  The elevations 
will update in the MicroStation view.

17. Review your results.

18. Set the Elevation precision back to .12
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19. <D> the Save and OK buttons.  The Survey Options dialog will close.

20. Use the MicroStation view commands    to zoom in, out, and pan the 
view.

Note: Notice how the text changes size and remains legible based upon the zoom ratio.

21. <D> MicroStation Fit View.  In the lower left hand corner of MicroStation the status bar 
states No Elements Found. 

Note: MicroStation Fit View command does not work because graphics displayed are 
dynamic graphics, not graphics written to the CADD file. 

22. From the pull-down menu, select Survey > Fit View or use Fit View button    from the 
View Survey toolbar.

23. Continue to Pan, Zoom and Fit the survey data until it is comfortable.  

24. Continue to toggle Survey display data on and off as needed.
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25. Explore the InRoads interface.  <D> the “+” (expand) button next to the Survey data 
12345SURVFieldbook01.fwd.  

26. The workspace bar will display the Station names. Select the Station name at the top 
CO RD 33. When the Station name is selected the Observations from that Station will 
display in the Information Window pane.



27. Continue to explore the 12345SURVFieldbook01 Survey Data.  Experiment right 
clicking in the different areas of the interface to find different useful shortcut menus. 
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Lab 2.3 - Viewing the Fieldbook Data

Open and explore some of the basic features of the electronic fieldbook.  The Fieldbook will be 
covered in greater detail later in the manual.

Section Objectives:

After completing this exercise you will know how to:

♦ Open the Fieldbook dialog.

♦ Find points in the Fieldbook dialog.

♦ Use the shortcut menus in the Fieldbook dialog.

♦ Use the Select Figure button.

♦ Use the chainage tool in the Fieldbook dialog.

1. <D> the Fieldbook    button from the Survey toolbar.  The Survey Fieldbook will 
appear.

2. Take a minute to review the electronic Fieldbook.
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3. In the column headers of the Stations <R> on the Station Name.  The 
Fieldbook Custom View dialog will appear.

Note: This dialog allows the order of the columns to be customized in the Fieldbook.

4. In the Mode section of the dialog <D> on the Observation radio button.

5. Select Target Height in the Selected: section on the right side.

6. <D> the Move Up button until Target Height rests under the Code.

7. <D> the OK button.  The Fieldbook Custom View dialog will close.
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8. Resize the Fieldbook so the column change for Target Height is in the view.

9. From the View Survey toolbar turn on only View Planimetrics   , View Symbols  

, and View Names  .  Turn off all other View Survey Data commands.

10. Select Station Name CO RD 33 in the top half of the Fieldbook Data dialog.  Notice 
that the bottom half of the dialog updated with the observations collected from that 
instrument setup.



Page 30 Colorado Department of Transportation

LAB 2 - Working with InRoads Survey Labs for Using InRoads Survey for Data Reduction

11. Select Point Name 2222 in the bottom half of the Fieldbook Data dialog.

♦ Use dialog scroll bars or

♦ Intelli-mouse wheel or

♦ Page Up or Page Down keys or

♦ Up or Down arrow keys

12. Right click on Point Name 2222 to access the shortcut menu.  Select Center from the 
available list.  Look in your MicroStation view Point Name 2222 is centered in View 1.

Note: Center only centers the point to the active view zoom ratio.  It may be necessary to 
zoom in closer and re-center from the shortcut menu.

13. Added Practice

♦ Find and Center Station Setup GAP 27_33 
Point Name 107

♦ Find and Center Station Setup Found monuments 
Point Name 1088_2
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14. From the pulldown menu Survey > Find Point in View the Find Point in View dialog 
will appear.

15. Type n the field Point Name: 2336 Radius: 50

16. <D> the Apply button.  The MicroStation view is updated and zoomed into point number 
2336.

17. <D> the Close button in the Find Point in View dialog.



Page 32 Colorado Department of Transportation

LAB 2 - Working with InRoads Survey Labs for Using InRoads Survey for Data Reduction

18. From the Fieldbook Data dialog <D> the Select Figure button.  The Fieldbook 
Data dialog will contract allowing more screen space to make a selection.

19. Select <D> at the start of the fence line.  The Fieldbook Data dialog will expand with 
point name 2336 selected.



Colorado Department of Transportation   Page 33

Labs for Using InRoads Survey for Data Reduction LAB 2 - Working with InRoads Survey

20. In the Fieldbook Data dialog <R> point name 2336 to access the shortcut menu and 
select Highlight Observations.  Notice at the start of the line segment the Box-X in 
MicroStation View 1.

Note: In the middle of the Fieldbook Data dialog there is an option to follow a 
chainage.  A chainage is a good way to follow a planimetric feature in the 
fieldbook and in the view.
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21. Use the chainage buttons 

♦ First    Previous    Next    and Last    to follow the fence line chain.  Notice 
the Highlighted Box-X that follows each point along the chain.  As the point continues 
outside the current view the point becomes centered in the MicroStation view.

22. When the end of the chainage is reached <D> the OK button.

23. Added practice

♦ From the west end of the project.

○ Follow the chainage for a code 1310 Edge of Oil

○ Follow the chainage for a code 6001 Terrain Breakline

Note: When having difficulty locating any chains try selecting the line segment instead 
of the start or end points.

24. Close the Fieldbook Data dialog by clicking the X in the upper right hand corner of the 
dialog.
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Summary:

 In Lab 2.1 -Opening Survey Data  the existing MicroStation file and InRoads Survey 
Fieldbook file was opened.

 In Lab 2.2 -CAD vs. Fieldbook Viewing the fieldbook data was viewed in the MicroStation 
view. 

 In Lab 2.3 -Viewing the Fieldbook Data the data in the fieldbook dialog was explored.
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LAB 3 - Feature Codes and Control Codes

Lab 3.1 - Viewing Survey Feature Table

The Survey Feature Table controls how the graphics are displayed on the screen.  These settings are the CDOT 
standard changes should not be made to the file.  However, it is a good to understand what controls the display 
of the survey data and how the data is interpreted.

Section Objectives:

♦ Open the Style Manager dialog.

♦ Use the Survey Properties option to narrow a lookup.

♦ Review Control Codes settings.

1. Launch InRoads Survey if it is not already;

a. Open 12345SurveyTopo100Scale01.dgn from the Working folder.

b. Open 12345SURV_Fieldbook.fwd from the Field_Books folder.

2. From the InRoads Survey pull-down menu, select Tools > Style Manager.  The Style 
Manager dialog will appear.

3. Take a minute to scroll through the list of Names.  Using the scroll bars on the side or 
using your roller on the mouse.
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4. In the Show Styles with Properties section of the dialog Check ON Include Survey.  The 
list of Names is filtered to show only the Feature Styles that are used in Survey.  Survey 
Feature Styles typically begin with “T_”.

5. Move your cursor to the Name and hold on the gray line in the gray title bar between Name 
and Description.  Your cursor will change appearance to a vertical line and arrows, 
allowing each column in the Feature Table to be resized.

6. Move the cursor to the Name and <D> on the column heading Name.  This will resort all 
the definitions in ascending or descending order.

7. <D> on the Numeric Code column twice to sort the codes in ascending and descending 
order.

8. <D> Hold and Drag on the Numeric Code column, move it next to the Name column.
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9. In the Survey Properties section Check ON Attributes. Notice how the feature list filters 
and displays only the survey features that have an attribute defined.

10. Check OFF the option Attributes to see all the codes again before continuing.

11. Locate the Style Name T_Coniferous Tree Numeric Code 3077 in the Style Manager 
dialog.

12. <D> the name and then <D> Edit button.  The Edit Style dialog will appear.



Page 40 Colorado Department of Transportation

LAB 3 - Feature Codes and Control Codes Labs for Using InRoads Survey for Data Reduction

13. <D> the Survey Feature leaf additional sub categories will appear.

14. <D> the sub categories under Survey Feature and review the setings. DO NOT make any 
changes.

15. When finished <D> the Close button do not apply or save any changes.

16. <D> the Close button in the Style Manager dialog. Do not save any changes.
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17. From the InRoads Survey pull down select Survey > Control Codes.  The Control 
Codes dialog will appear.

18. Review the Control Codes refer to the reference material for explanation of the codes.

19. <D> the Cancel button.  The Control Codes dialog will close not saving any changes.

Section Summary:
♦ In this lab the Style Mannger was opened and the settings were explored.

♦ In this lab the Control Codes dialog was opened.
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LAB 4 - Exporting the Fieldbook - Overview

Lab 4.1 - Exporting Survey Data to Graphics - Overview

InRoads Survey can export the fieldbook in 3 different formats. These formats are CAD graphics, Surfaces, 
and Alignments.  Begin by exporting graphics to a MicroStation DGN file. This will create a basemap to be 
used and referenced by the designers.

Section Objectives:

♦ Know what to modify in Survey Options prior to exporting.

♦ Export a Survey Fieldbook to a design file.

♦ Know the difference between CAD and Fieldbook viewing.

♦ Work with Survey levels and level filters.

1. Launch InRoads Survey if it is not already;

a. Open 12345SurveyTopo100Scale01.dgn from the Working folder.

b. Open 12345SURV_Fieldbook.fwd from the Field_Books folder.

2. Disable the display of any dynamic graphics shown on the screen.

Toggle on View Planimetrics button   turn off any other symbols, names, codes, etc. 
that may have enabled.

3. Verify the 12345SURV_Fieldbook.fwd fieldbook is active.  The fieldbook that is active has 
the red box around the fieldbook button.
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4. To modify the scale as it relates to cells, text, and linestyles go to 
Tools > Survey Options > [General]. The Survey Options dialog will appear.

5. Set the Scales for Cell, Text, and Line as shown below.

♦ Cell Scale:100
♦ Text Scale:20
♦ Line Scale:100

6. <D> the OK button.  The Survey Options dialog will close.

7. Once the settings are complete, to write the survey data to graphics, go to the InRoads pull 
down menu Survey > View Survey Data > Write Survey Data to Graphics… the 
Write Survey Data to Graphics dialog will open.

Note: By default having any dynamic graphics still toggled on, those same components 
would be toggled on in the Write Survey Data to Graphics dialog.

8. Set Curve Stroking: Horizontal Only
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9. <D> the Apply button. The graphics will be created in the design file.

10. Watch the Status Bar as the graphics are written to the design file.

11. <D> the Close button in the Write Survey Data to Graphics dialog. 

12. Toggle off all View Survey buttons.

13. From the InRoads Survey pull-down Survey > Find a Point in a View the 
Find a Point in a View dialog will appear.

14. Key-in Point Name: 2336

15. Key-in Radius: 50

16. <D> the Apply button.  The MicroStation view will center to shot number 2336.

Note: The graphics displayed are MicroStation elements written to the design file.  The 
graphics become independent from the survey data.  There is no linkage from the 
MicroStation graphics back to the survey data.  Therefore it is important to 
remember that if changes to the survey data are made, the survey data will need to 
be rewritten to the CAD file after editing.
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To demonstrate this concept, use MicroStation tools to manipulate the displayed survey 
graphics.

17. Delete, move, or otherwise modify the on-screen graphics.

18. Review the survey fieldbook    to verify data integrity.

19. Toggle on dynamic display of Planimetrics   Notice the location of the fieldbook data 
vs. the modified MicroStation graphics.

20. Toggle off dynamic display of Planimetrics  



Colorado Department of Transportation   Page 47

Labs for Using InRoads Survey for Data Reduction LAB 4 - Exporting the Fieldbook - Overview

21. From the MicroStation Primary Tools toolbar <D> the Level Display dialog.  The Level 
Display dialog will appear.

22. From the filters pull-down select the Topo > Fence filter.

23. Practice turning ON and OFF the fence levels in MicroStation.
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24. From the filters pull-down select the Topo filter.  This will help when viewing only the 
levels that pertain to the survey data.

Added practice:

♦ Sort the Name and Used columns by clicking on them.

♦ Right click on the level names to view the level popup options. Practice using these 
shortcuts.

25. Close the Level Display dialog.
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Lab 4.2 - Exporting Survey Data to Surface Overview

Exporting to a surface DTM will create a triangulation network used for displaying contours, features and spot 
elevations.

Section Objectives:

♦ To export a Survey Fieldbook to a Surface DTM file.

♦ Triangulate a surface.

♦ Set the surface property for display.

♦ Save a Surface DTM file.

1. Verify the 12345SURV_Fieldbook fieldbook is active. The active fieldbook will have a red 
box around the fieldbook button.

2. From the pull-down menu, select File > New.  The New dialog will appear.

3. Select the Surface tab.

4. Key in the surface Name: 12345SURVSurface01

5. Key in the Description: CDOT Surface Overview Training

Note: Key in any additional file information in the Description field of the dialog, such 
as Date, User, and Design file name. There are up to 64 characters available in the 
Description field.

6. Keep the Maximum Length set to 0.00

7. Set Preferences: Existing 10’ Mjr – 2’ Minor

8. <D> the Apply then Close buttons.
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9. From the pull down menu Survey > Survey Data to Surface.  The Survey Data to 
Surface dialog will appear.

10. Pick 12345SURVSurface01 in the Surface Name field.

11. Set the Description to Use Style Description

12. Keep the Tolerance and Maximum Segment Length set to 0.00

13. Set the Curve Stroking Mode to Horizontal Only

14. Check Always Use: Style

15. Check Triangulate Surface

16. <D> the OK button and the Triangulate Surface dialog will appear.

17. Leave all settings unchecked. Maximum Length should be set to 0.00.
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18. <D> the Apply button.  The Results section of the dialog should look similar to the image 
below.

19. <D> the More button. The Surface Properties dialog will appear.

20. Verify the correct surface is being used 12345SURVSurface01.

21. Review the section for Data Range.  The Easting, Northing, and Elevation values should 
fall within the project limits.
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22. <D> the Advanced tab.

23. In the Cross Sections Section select Symbology: T_Existing Ground

24. In the Profiles section select Symbology: T_Existing Ground

25. <D> Apply then Close buttons in the Surface Properties dialog.

26. <D> the Close button in the Triangulate Surface dialog.

27. Use the Workspace Bar pane scroll arrows to view the Surfaces tab.

28. Verify 12345SURVSurface01 is the active surface.

Note: To change the active surface from the pull-down menu 
Surface > Active Surface; highlight the surface name and
 <D> the Apply button.
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29. From the InRoads pull down menu select File > Save > Surface.  The Save As dialog 
will appear with the Save as type set to Surfaces (*.dtm).

30. Verify the correct project directory C:\Projects\12345\ROW_Survey\Working

31. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Surface name in the project folder matches the Surface 
name displayed in InRoads explorer will minimize any confusion.

32. <D> the Save then Cancel buttons.  The file will be saved to disk and the Save As dialog 
will close.
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Lab 4.3 - Exporting Survey Data to Geometry Overview

These steps show how to export the electronic fieldbook to a Geometry Project or ALG file.  Exporting to an 
ALG file will create horizontal and vertical alignments.  InRoads refers to all exported topographic strings as 
alignments. InRoads will also write all survey shot locations to the Cogo buffer.  The alignments and Cogo 
points will then be available for use for Right-Of-Way or design purposes.

Section Objectives:

♦ To export a Survey Fieldbook to a Geometry Project.

♦ To view the geometry project in the InRoads interface.

♦ To save a Geometry Project.

1. Verify the 12345SURVFieldbook01 fieldbook is active.  The fieldbook that is active has 
the red box around the fieldbook button.

2. From the pull-down menu, select File > New.  The New dialog will appear.

3. Select the Geometry tab.

4. From the type pick list verify the Type: Geometry Project

5. Key in the geometry Name: 12345SURVGeometry01

6. Key in the Description: CDOT Geometry Overview Training

Note: Key in any additional file information in the Description field of the dialog, such 
as Date, User, and Design file name. There are up to 79 characters available in 
the Description field.

7. <D> the Apply and Close buttons.
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8. From the pull-down menu, select Survey > Survey Data to Geometry.  The 
Survey Data to Geometry dialog will appear.

9. In the Project Name: 12345SURVGeometry01

10. Set the Description: Use Style Description

11. Set the Curve Stroking: Horizontal Only

12. <D> the Apply then Close buttons.

13. Use the Workspace pane scroll arrows to view the Geometry tab.

14. Verify 12345SURVGeometry01 is the active Geometry Project.  

Note: To change the active Geometry from the pull down menu 
Geometry > Active Geometry then highlighting the desired geometry project 
name and <D> the Apply button.
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15. From the pull-down File > Save > Geometry Project.  The Save As dialog will 
appear with the Save as type set to Geometry Projects (*.alg).

16. Verify the correct project directory C:\Projects\12345\ROW_Survey\Working

17. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Geometry name in the project folder matches the 
Geometry name displayed in InRoads explorer will minimize any confusion.

18. <D> the Save then Cancel button.  The file will be saved to disk and the Save As dialog 
will close.

19. From the Inroads pull down menu select, File > Exit

20. From the MicroStation pull down select, File > Save Settings

21. From the MicroStation pull down select,  File > Exit

The existing fieldbook has been exported and created 3 specific files from the Survey data. The 
MicroStation Design file (DGN), an InRoads Surface (DTM), and InRoads Geometry Project 
(ALG).

In the next section a fieldbook will be created from scratch and then look at the entire process 
in more detail.  This was merely an overview to help getting familiar with the product and to 
begin to be familiar with the overall workflow. The next sections will work as reinforcement of 
the workflow process.
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Lab 5.1 - Managing Survey Files

In Section 1 of the training a fieldbook, design file, surface model, and geometry project were 
created.  Consider that work to be out of date and those files will need to be managed in the 
Working directory.

1. Open Windows Explorer and path to the directory 
C:\Projects\12345\ROW_Survey\Working

2. Rename the working file with your initials and date YYYY-MM-DD for example 
RBM12345SurveyTopo100Scale01_2009-11-04.dgn

Note: Eventually when the design file has been finalized it will be moved to the 
ROW_Survey\Drawings\Reference_Files\ directory for use by the rest of the 
project team.
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Lab 5.2 - Importing Control Files

Section Objectives:

♦ Import a CDOT survey control file that has the points fixed positions.

♦ View the control file points in the fieldbook dialog and in the MicroStation view.

1. Double-click on the InRoads Survey desktop button    or select 
Start > All Programs > Bentley > InRoads Group XM > InRoads Survey.

2. In the MicroStation Manager dialog go to the Workspace group section and change
User: CDOT User
Project: 12345
Interface: CDOT
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3. In the MicroStation Manager dialog path to the directory: 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

4. Select the file 12345SURV_Topo##Scale##.dgn from the MicroStation Manager 
dialog.

Note: The purpose of the files with “##” symbols are for creating new files with the 
correct naming convention.

5. <D> Open the MicroStation Manager dialog will close and open the file.

6. From the MicroStation pull-down menu File > Save As the Save As dialog will appear.

7. Path to the folder C:\Projects\12345\ROW_Survey\Working

8. Replace the ## symbols with 100 scale and 01 model. 
Type in Files: 12345SURV_Topo100Scale01.dgn
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9. <D> the Save button the Save As dialog will close and MicroStation will open the file 
12345SURV_Topo100Scale01.dgn.

10. Once MicroStation and InRoads opens. From the InRoads pull down menu, select 
File > New.  The New dialog will appear.
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11. Select the Survey Data tab.

12. Key in the Name: 12345SURVFieldbook01

13. <D> the Apply button. The new survey fieldbook will appear below.

14. <D> the Close button. The New dialog will close.

15. From the Workspace bar the 12345SURVFieldbook01 will be active.
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16. From the pull-down menu, select File > Import > Survey Data. The Import dialog will 
open.

17. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

18. Verify the Files of type: CDOTCTL (*.CTL)

♦ Importing the CTL file first is only needed if the field books being imported are 
conventional files.  GPS (positional) files do not require the CTL file.

Note: The Files of type: drop-down box works as a filter.  Allowing to the files that 
have the particular file extensions to be viewed.  This allows InRoads Survey to 
utilize a specific import wizard for each file type.
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19. <D> the Options button.

Note: This is the same dialog that can be opened from Tools > Survey Options
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20. Verify the Cell, Text, and Line Scales are all set to 100, 20 ,100

21. Verify Fieldbook Audit Trail File Name is still set from Section 1.
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\
”UserInitials”_FieldBookEdits.log

22. <D> the OK button.  The Survey Options dialog will close.

23. <D> the Import button.  The Import dialog will remain open allowing  additional files to 
be imported.
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24. <D> the Close button.

Note: Upon closing, InRoads Survey executes the import routine.

25. From the pull-down menu, select Survey > Fieldbook Data….  Take a minute to review 
the imported Survey control data that is now contained in the electronic Fieldbook.

26. While the Fieldbook Data dialog is open, also look at the MicroStation view and 
displayed graphics.

27. Practice changing the display graphics using the View Survey Data toolbar.

28. Continue to practice zooming and panning using the MicroStation view border buttons.

29. Close the Fieldbook Data dialog.

30. Fit View from the View Survey Data toolbar.
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It is up to the user to determine when to save the data in InRoads Survey.  Until now the 
fieldbook is being stored in memory. If something was to cause InRoads to close, your data 
would be lost.

31. File > Save > Survey Data the Save As dialog will open.

32. Verify the directory location:
C:\Projects\12345\ROW_Survey\InRoads\Field_Books

33. Choose the Active: 12345SURVFieldbook01 at the bottom of the dialog.

34. Verify the File Name: 12345SURVFieldbook01.fwd
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35. <D> the Save button.  The file will be saved to disk and will show in the dialog.

36. <D> the Cancel button.  The Save As dialog will close.
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Lab 5.3 - Importing Data collector files

Section Objectives:

♦ Import multiple raw Sokkia SDR topo files into the InRoads Survey fieldbook file.

♦ Import a raw Trimble DC topo file into the InRoads Survey fieldbook file.

♦ Create an error log file for keeping track of code errors in the fieldbook file.

♦ Correct code error problems using the Resolve Code Error dialog.

♦ Review topo points in the Fieldbook dialog and MicroStation view.

Importing SDR files

1. From the Workspace bar select and highlight 12345SURVFieldbook01 and <R> to view 
the shortcut menu.

2. <D> Import… The Import dialog will appear.

♦ This is a same as using the pull-down menu File > Import > Survey Data.
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3. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

4. Change the drop-down arrow Files of type: Sokkia SDR (*.sdr)

5. Select the file 12345AAAIR.sdr from the filtered list of files.

6. <D> the Import button.  The Import dialog will remain open allowing additional files to 
be imported.

7. <D> the Close button.
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8. Select the Fieldbook    button from the Survey toolbar.  The Survey Fieldbook will 
appear.

9. Take a minute to review the observations from Station Name 2000 that was imported into 
the electronic Fieldbook.

10. Close the Fieldbook dialog <D> the X in the upper right hand corner of the dialog.

Resolving Code errors

From the Tools > Survey Options dialog the choice was made to resolve any code errors 
when the data is imported. There are a couple of ways to handle code errors.

1. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

2. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

3. Verify the drop-down arrow Files of type: Sokkia SDR (*.sdr)

4. Select the file 12345BBBIR.sdr from the filtered list of files.

5. <D> the Import button.  Only one file can be selected at a time.  The Import dialog will 
remain open allowing for additional files to be imported.
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6. <D> the OK button in the SDR Tolerance dialog box.

7. <D> the Close button.  The imported SDR files will be processed.

Note: There are code errors with these files; the Resolve Code Errors dialog will appear.

8. Key-in Change To: 1699

9. <D> the Retry button.  The code will be processed and the next error will appear.  

Continue this process for the next three code errors.

10. Key-in Change To: 5182 <D> the Retry button.



Page 72 Colorado Department of Transportation

LAB 5 - Importing Data Labs for Using InRoads Survey for Data Reduction

11. Key-in Change To: 4210.08 ST <D> the Retry button.

12. Key-in Change To: 4274 <D> the Retry button.  The Resolve Code Error dialog will 
close and Survey will process the data.

13. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

14. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

15. Verify the drop-down arrow Files of type: Sokkia SDR (*.sdr)
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16. Select the file 1234500CCCIR.sdr from the filtered list of files.

17. <D> the Import button.  The Import dialog will remain open allowing for additional files 
to be imported.

18. Continue to import the remaining SDR files 1234500DDDIR- 123450EEEIR

♦ If a previously imported SDR file was selected the following dialog will appear.

19. <D> the No button and go back and select a different file.
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Importing Trimble DC file

20. Change the drop-down arrow Files of type: Trimble DC (*.dc)

21. Select the file 12345FFFIR.dc from the filtered list of files.

22. <D> the Import button.  The Import dialog will remain open allowing for additional files 
to be imported.

23. <D> the Close button.  If errors are present in the input files, the Resolve Code Errors 
dialog will appear.

24. <D> the Log File Name key in field. The Browse button will become activated.
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25. <D> the Browse button in the Resolve Code Error dialog.  The Browse dialog will appear.

26. Path to the Save in folder C:\Projects\12345\ROW_Survey\InRoads\Field_Books.

27. Key in the file name ResolveCodeErrors_All.log

28. <D> the Save button the Browse dialog will close and the file name and path will appear 
in the Log File Name field.
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29. <D> the Ignore All button.  The Results dialog will appear showing the errors and the log 
file will be saved.

30. <D> the Close button in the Results dialog.  Those errors will be addressed later in this 
lab.

31. Select the Fieldbook    button from the Survey toolbar.  The Survey Fieldbook will 
appear.

32. Take a minute to review the observations from Station Name 12345FFFIR that was 
imported into the electronic Fieldbook.
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33. Locate Station Name: 12345CCCIR Point Name: 13619.  Notice the code is red, 
representing an error.

Note: While the Fieldbook Data dialog is open, look at the MicroStation view and 
displayed graphics.

34. Locate the same point in View 1 using one of the following methods.

♦ <R> Point Name to view the Fieldbook shortcut list and select Center
or
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♦ From the pull-down menu, select Survey > Find Point in View

Note: The code errors will be corrected in the fieldbook later in the lab.

35. Close the Fieldbook dialog and any other dialogs.
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Lab 5.4 - Importing ASCII files

In the following steps an ASCII file will be imported.  To import ASCII files the Text Import 
Wizard (TIW) will be used.  This format created for importing text can be saved and recalled 
for future use.

Section Objectives:

♦ Import a custom ASCII report with the Text Import Wizard.

♦ Create a new standard import selection for future use.

♦ Review the points in the Fieldbook file and MicroStation view.

1. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

2. Change the Look in: folder to C:\Projects\12345\ROW_Survey\Survey\Raw_Data

3. Change the drop-down arrow Files of type: Text File (*.*)  All the files in the directory 
will be shown.
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4. Select the file 12345TestHoles.xyz

5. <D> the Import button.  The Text Import Wizard dialog will appear.

6. Change the entry field Start Import at Row: 7 and Tab out of the field. This will ignore 
the header information in the file.

7. Verify the Record Format radio button is set to Uniform.
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8. Verify the Original Data Type radio button is set to Delimited.

9. <D> the Next > button.  The Step 2 of 3 dialog will appear.

10. In the Delimiters section of the dialog check on the Comma delimiter field as this 
defines what separates our columns of data.  Verify the rest of the dialog is set as shown 
below.
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11. <D> the Next > button.  The final Step 3 of 3 dialog will appear.
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12. Select the header of the first column labeled Skip.  The column will highlight as shown 
below.

13. From the Column Data Format drop-down box select Point Name

14. Select the second Skip column header then select Easting from the Column Data Format 
drop-down box.

15. Select the third Skip column header then select Northing from the Column Data Format 
drop-down box.

16. Select the fourth Skip column header then select Elevation from the Column Data 
Format drop-down box.

17. Select the fifth Skip column header then select Code from the Column Data Format 
drop-down box.
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18. <D> the Save As button.  The Save As dialog will appear.

19. Key in File name: ASCII Import ENEc

20. <D> the Save button.  The Save As dialog will close and and error dialog will appear.

Note: Because files can not be saved to the Program Files directory on the computer the file 
will default to the users login C:\Users\cdot\Documents folder structure.

21. <D> the Yes button. The Save in the CDOT User folder will appear.
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22. <D> the Save button and the dialog will close.

23. The Save Format to File Types dialog will appear.  Verify Format Name: ASCII 
Import ENEc

24. <D> the Yes button.  The Save Format to File Types dialog will close and the Step 3 of 3 
dialog will reappear.

Note: The Text Import Wizard has been created for future use.

25. In the Step 3 of 3 dialog <D> the Cancel button.  The Step 3 of 3 dialog will close and the 
Import dialog will reappear.

26. In the Import dialog change the Files of type: ASCII Import ENEc (*.xyz)

Note: The extension for the filter (*.xyz) came from the original file extensions that was 
imported.
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27. Select the file 12345TestHoles.xyz

28. <D> the Import then Close buttons.

29. <D> Ignore All in the Resolve Code Error dialog and then close the dialog.  

Note: The Resolve Code Error dialog continues to open because the entire file is 
processed each time a file is imported.

30. <D> the Close button in the Results dialog.

31. Review the data that was imported Survey > Fieldbook Data…
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32. Locate the file that was imported into the Fieldbook Data dialog.  As files are imported 
to the fieldbook they will always append to the active fieldbook.

33. Select Point Name 20006 in the fieldbook.

34. <R> Center Point Name 20006 to the MicroStation view.

Note: The center command from the shortcut menu works with the current zoom ratio 
and will not zoom into the point.
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35. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.

36. The Status Bar will show that it was saved.
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Section Summary:
♦ In Lab 5.1 -Managing Survey Files the working directory was cleaned up to avoid any 

name conflicts.

♦ In Lab 5.2 -Importing Control Files the CDOT survey control file was added first to 
the InRoads Survey fieldbook file.

♦ Lab 5.3 -Importing Data collector files additional raw survey topo files from a Sokkia 
and Trimble data collectors were added to the InRoads Survey fieldbook file.

♦ In Lab 5.4 -Importing ASCII files a custom ASCII file was imported into the InRoads 
Survey fieldbook file and the settings were stored in the product for future use.
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Lab 6.1 - Correcting Fieldbook Code Errors

Errors may include Survey Feature Styles (numeric codes) that are not defined in the Style Manager or control 
codes that are not defined by Survey>Control Codes.

Section Objectives:

♦ Find and correct feature coding errors.

Use the log file that was generated when importing the raw survey data. This file logged all errors to be 
corrected.   ResolveCodeErrors_All.txt

 

1. <D> the Fieldbook  button from the Survey tool bar.  The Survey Fieldbook will appear.

2. From the Fieldbook dialog select the Find / Replace Codes   button.  The Point 
Code Find a Replace dialog will appear.

3. Select the Next Error button.  The command will look in the current fieldbook and return 
the first code error it finds.

Note: This error has an incorrect Control Code for Close.
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4. Type the correction in the field Replace with: 6001.00210 CL

5. <D> the Replace button.  The code in the fieldbook will be updated.  The dialog will 
automatically locate the next error which is the first of multiple shots incorrectly coded as 
675

6. In the Point Code Find and Replace dialog, Replace code 675 with code 6075

7. <D> the Replace All then Close buttons to replace the mis-coded points.

8. If not still open, reopen the Find Observation dialog by <R> on an observations in the 
Fieldbook Data dialog and select Find from the popup menu.

9. Key-in the Point Name: [13995-13997]

Note: The point range must be enclosed in brackets.

10. <D> the Apply button.  The point names within the defined range populate the list.



Colorado Department of Transportation   Page 93

A Practical Guide for Using InRoads XM LAB 6 - Fieldbook Edits

11. Select the point name 13995 and <R>. From the popup menu select Center.  The point 
13995 will center to  MicroStation View 1.

Note: The current zoom factor for the window will not change.
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12. From the Find Observation dialog select the Edit button.   The Edit Observation dialog 
will appear.

13. Type in the Code: 1330.50 BC NT

14. <D> the Apply button.

15. <D> the Next    button at the top of the dialog, stop at point 13997.



Colorado Department of Transportation   Page 95

A Practical Guide for Using InRoads XM LAB 6 - Fieldbook Edits

16. Type in the Code: 1330.50 EC NT

17. <D> the Apply the Close buttons.  Review your results in MicroStation View 1.

18. From the Fieldbook dialog select the Find / Replace Codes    button.  The Point 
Code Find a Replace dialog will appear.

19. <D> the Next Error button.  The command will look in the current fieldbook and return 
the first code error it finds.
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20. <D> the Close button.  The incorrect point will be located in the Fieldbook Data dialog.

Note: This error has an incorrect Feature Code for a power pole.

21.  In the Fieldbook Data dialog <R> on the point name 8697 from the popup menu select 
Center. The point name will be centered to the MicroStation View 1.

22. Again in the Fieldbook Data dialog <R> on the point name 8697 from the popup menu 
select Edit.  The Edit Observation dialog will appear for point 8697.
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23. Type in the Code: 4375

24. <D> the Apply then Close buttons.  In the MicroStation View 1 the point has been 
updated and a power pole cell is at the location.

25. From the Fieldbook dialog select the Find / Replace Codes    button.  The Point 
Code Find a Replace dialog will appear.
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26. Select the Next Error button.  The command will look in the current fieldbook and return 
the first code error it finds.

Note: This error has an incorrect Control Code for Start.

27. Type the correction in the field Replace with: 6001.00210 ST

28. <D> the Replace button.  The code in the fieldbook will be updated.  The dialog will 
automatically locate the next code error  5177 3'X3'STEEP HILL

29. <D> the Close button in the Point Code Find and Replace dialog.  The point name 8780 
will be selected in the Fieldbook Data dialog.

30. <R> the point name 8780 and from the popup menu select Edit.  The Edit Observation 
dialog will appear.

This error is because a note is entered into the code field.  The note will be cut and then pasted 
into the Notes field, where it belongs.

31. In the Code field highlight the additional text in the code line “3'X3'STEEP HILL”

32. <R> on the highlighted note and select Cut from the popup menu.
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33. <D> in the Notes field so the field has focus.

34. <R> in the Notes field and select Paste from the popup menu.

35. In the Edit Observation dialog <D> the Apply then Close buttons.

36. From the Fieldbook dialog select the Find / Replace Codes    button.  The Point 
Code Find a Replace dialog will appear.

37. Select the Next Error button.  The command will look in the current fieldbook and return 
the last coding error in this fieldbook.

38. <D> the Close button in the Point Code Find and Replace dialog.  The point name 10153 
will be selected in the Fieldbook Data dialog.

39. <D> <D> the point name 10153.  The Edit Observation dialog will appear.
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Again this error is because of the note being entered into the code field.  The note will be cut 
and then pasted into the Notes field, where it belongs.

40. In the Code field highlight the additional text in the code line “ICE”

41. <R> on the highlighted note and select Cut from the popup menu.

42. <D> in the Notes field so the field has focus.

43. <R> in the Notes field and select Paste from the popup menu.

44. In the Edit Observation dialog <D> the Apply then Close buttons.

This should have taken care of all errors in the fieldbook.  

45. Verify this by opening the Point Code Find and Replace dialog and selecting Next Error.  
An alert dialog will appear stating that no errors exist in the fieldbook.

46. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.
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Lab 6.2 - Correcting Fieldbook Control Code Errors

Control codes are the drawing tools for InRoads Survey.  When collecting data in the field think of the range 
pole as a large pencil and using control codes allows you to draw the lines.  Even though CDOT has 
standardized on Numeric feature codes, InRoads Survey is configured to allow the use of Alpha control codes 
only. 

Section Objectives:

♦ Find and correct control coding errors.

♦ Add additional control coding to observations.

1. From the pull-down menu Survey > Find Point in View The Find Point in View dialog 
will appear.

2. Key-in the Point Name: 22006
                          Radius: 50
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3. Open the Fieldbook Data dialog Survey > Fieldbook Data

4. From the Fieldbook Data dialog <D> the Select Observation    target button.  The 
Fieldbook Data dialog will minimize allowing more of the view to be displayed.
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5. <D> point 22006 in the MicroStation View 1.  The Fieldbook Data dialog will restore to 
the screen and the point name 22006 will be highlighted in dialog.

6. <D> <D> the point name 22006.  The Edit Observation dialog for point 22006 will appear.

The brick house point code is missing the control code ST to start the line work.  Also the 
distance control code DIST will be utilized to complete the planimetrics of the house.

7. Type in the Code: 4111 ST

8. <D> the Apply button.  The line work for the house will start.

9. <D> the Next    button in the Edit Observation dialog stop at point name 22007.

10. Type in the Code: 4111 DIST -70 -30 -20 40 CL
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11. <D> the Apply button.

Note: A positive number will place the line to the right of the two base line points.  A 
negative number will place the line to the left side of the two base line points.

12. Locate point name 22008 in the Fieldbook Data dialog. Also center it in the MicroStation 
window.

13. <D> <D> the point name 22008.  The Edit Observation dialog will appear.

The next edits will be to create the deck on the back of the house using two shots and a 
measured distance with the rectangle RECT control code.
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14. Type in the Code: 4127 ST

15. <D> the Apply button.  The line work for the deck will start.

16. <D> the Next    button in the Edit Observation dialog stop at point name 22009.

17. Type in the Code: 4127 RECT 25

Note: A positive number will place the rectangle on the right side of the two base line 
points.  A negative number will place the rectangle on the left side of the two base 
line points.
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18. <D> the Apply button the rectangle control code will have finished creating the line work. 

19. Locate point name 22010 in the Fieldbook Data dialog. Also center it in the 
MicroStation window.

20. <D> <D> the point name 22010.  The Edit Observation dialog will appear.

The next edits will be to create the shed using three shots with the close rectangle CLR control 
code.

21. Type in the Code: 4113 ST

22. <D> the Apply button.  The line work for the deck will start.

23. <D> the Next    button in the Edit Observation dialog stop at point name 22012
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24. Type in the Code: 4113 CLR

25. <D> the Apply button the close rectangle control code will have finished creating the line 
work. 



Page 108 Colorado Department of Transportation

LAB 6 - Fieldbook Edits A Practical Guide for Using InRoads XM

The watermain and a hydrant have been surveyed  The control code JNC will be utilized to tie 
the hydant to the watermain.

26. From the pull-down menu Survey > Find Point in View The Find Point in View dialog 
will appear.

27. Key-in the Point Name: 22000
                          Radius: 100

28. Locate point name 22000 in the Fieldbook Data dialog.

29. <D> <D> the point name 22000.  The Edit Observation dialog will appear.

<D> the figure shown in the MicroStation View 1.  The Fieldbook Data dialog will restore to 
the screen and the point name 8026 will be highlighted in dialog.

30. Type in the Code: 4710 ST

31. <D> the Apply button.  The line work for the deck will have started.

32. <D> the Next    button in the Edit Observation dialog stop at point name 22002
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33. Type in the Code: 4710 JNC 4775

Note: The Join Nearest Code JNC will locate the nearest fire hydrant 4775 feature code 
and connect a line to that code.

34. <D> the Apply button the Join Nearest Code control code will have finished creating the 
line work.

The next edits will smooth he edge of driveway using the begin curve BC control code.

35. From the pull-down menu Survey > Find Point in View The Find Point in View dialog 
will appear.
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36. Key-in the Point Name: 22003
                          Radius: 50

37. From the Fieldbook Data dialog <D> the Select Figure    target button.  The 
Fieldbook Data dialog will minimize allowing more of the view to be displayed.
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38. <D> the figure shown in the MicroStation View 1.  The Fieldbook Data dialog will restore 
to the screen and the point name 8026 will be highlighted in dialog.

39. <D> <D> the point name 8026.  The Edit Observation dialog for point 8206 will appear.
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The figure shown in plan view has sharp edges and should be smoothed for a better looking 
basemap.

40. Type in the Code: 1331.07 ST BC

41. <D> the Apply button.  The line work for the figure will be smoother.
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42. Continue to edit the rest of the Dirt Driveway figures in the area with the Begin Curve BC 
control code.

The next edit will be to rotate culvert end wall to the correct orientation

43. From the pull-down menu Survey > Find Point in View The Find Point in View dialog 
will appear.

44. Key-in the Point Name: 7026
                          Radius: 15

45. Locate point name 7026 in the Fieldbook Data dialog.

46. <D> <D> the point name 7026.  The Edit Observation dialog will appear.

The next edits will be to rotate the culvert end sections into the direction of the pipe.
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47. Move your mouse to the Attributes section of the dialog and <D> the Value for Code 2062.  
The Value field will open allowing keyboard input.

48. Type in the Value: 270

49. <D> the Apply button.  The end section cell will have rotated into the direction of the 
pipe.

50. <D> the Next    button in the Edit Observation dialog to locate point name 7033 which 
is the east end of the pipe.

51. Type in the Value: 90
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52. <D> the Apply then Close buttons.  The end section cell will have rotated into the 
direction of the pipe.

The next edits will be to change the feature code 3033 (tree grove) to run counter clockwise 
CCW so the planimetrics will be correct.

53. From the pull-down menu Survey > Find Point in View The Find Point in View dialog 
will appear.

54. Key-in the Point Name: 7734
                          Radius: 40

55. Locate point name 7733 in the Fieldbook Data dialog.

56. <D> <D> the point name 7733.  The Edit Observation dialog will appear.

57. Move your mouse to the Codes section of the dialog.

58. Type in the Code: 3033.01 ST

59. <D> the Apply then Close buttons.  The change in direction for the feature code will 
correct the planimetric display.
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Note: Notice that at this point the entire display of the line has disappeared.  The 
remaining shots that make up this figure will also need to be changed to feature 
code 3033.

60. In the Fieldbook Data dialog <D> the point name 7734, then holding down the Shift key 
<D> the point name 7738.  A selection set of points 7734-7738 have been highlighted in 
the fieldbook.

61. <R> the select point list. From the popup menu select Edit.

Note: Notice that the only fields that can be edited are the ones that are identical among 
the selected observations.
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62. Type in the Code: 3033.01

63. <D> the Apply then Close buttons.  The planimetrics will display correctly.

64. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.



Page 118 Colorado Department of Transportation

LAB 6 - Fieldbook Edits A Practical Guide for Using InRoads XM

Lab 6.3 - Correcting Elevation Errors

There are four shots (7733-7736) that were collected with incorrect rod heights (16.0’ vs. 6.0’).  The shots can 
be located and edited as a group.

Section Objectives:

♦ Find observations based on search criteria

♦ Correct multiple observations with a single operation.

1. <D> the Fieldbook    button from the Survey tool bar.  The Survey Fieldbook will 
appear.

2. In the Fieldbook Data dialog <R> any Point Name in the observation section of the dialog.  
From the shortcut menu Select Find.  The Find Observation dialog will appear.

3. Target Height
Minimum: 15
Maximum: 17

4. <D> the Apply button.

5. <D> the first point in the list. The Fieldbook focus will move to that point.

6. Close the Find Observation dialog

7. Select observations 7733-7736 

Note:  Use the Shift and Ctrl keys on the keyboard to select and deselect multiple points 
in the Find Observation list.



Colorado Department of Transportation   Page 119

A Practical Guide for Using InRoads XM LAB 6 - Fieldbook Edits

8. <r> and select Edit… from the flyout menu.  The Edit Observation dialog will appear.

9. Type the correct Target Height: 6.00 

10. <D> the Apply then Close buttons to accept the change for all the selected points.

11. Verify the change was applied to the observations.

12. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.
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Lab 6.4 - Adding points to the fieldbook

The ability to add points to a fieldbook is simple to accomplish.  Points can be added based on computed, 
fixed, or known geometry locations.

Section Objectives:

♦ To add an observation to a fieldbook by selecting the location graphically from the 
MicroStation file.

♦ Define the elevation for the added point and add notes to the observation.

In this example a tree will be added to the fieldbook.

1. In the MicroStation view Find Point Name: 8030 Radius: 30

2. In the InRoads Survey Fieldbook Locate point 8030
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3. <R> the point name 8030 and select Add After from the shortcut menu.  The Add 
Observation dialog will open.

Note: The Point Name field will populate with the next available number starting with the 
Point Seed  number defined in Survey Options.

4. Type in the Code: 3077

5. <D> the Target button for the Northing Easting and Elevation.  The Add Observation 
dialog will minimize. <D> a point in the MicroStation view somewhere inside the island of 
the driveway.  The Add Observation dialog will reappear.

6. Type in the Elevation: 6535.00

7. Type in the Note: Point added graphically
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8. <D> the Apply then Close buttons.  The tree will dynamically display in the MicroStation 
view.

9. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.

Section Summary:
♦ In Lab 6.1 -Correcting Fieldbook Code Errors tools were used to both find and correct 

codes that were incorrectly logged in the data collector.

♦ In Lab 6.2 -Correcting Fieldbook Control Code Errors control codes were corrected. 
Additionally control code additions were made to observations to refine the data 
collected.

♦ In Lab 6.3 -Correcting Elevation Errors search criteria was used to locate a group of 
observations. A single edit was executed to correct multiple observations.

♦ In Lab 6.4 -Adding points to the fieldbook an additional observation was added to the 
electronic fieldbook based on a graphic location.
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Lab 7.1 - Exporting Survey Data to Surface for Evaluation

Exporting to a DTM surface will create a triangulation network used for displaying contours, features and spot 
elevations.

1. Verify the 12345SURVFieldbook01 fieldbook is active as this is the survey data to be 
exported to a DTM.  You can tell which fieldbook is active by the red box around the 
fieldbook button.

2. Write Survey Data to Graphics if they are not already.  The planimetrics will make viewing 
in the MicroStation model easier.

3. From the pull-down menu, select File > New.  The New dialog will appear.

4. Select the Surface tab.

5. Key in the surface Name: 12345SURVSurface01

6. Key in the Description: CDOT Surface Evaluation

Note: Key in any additional file information in the Description field of the dialog, such 
as Date, User, and Design file name. You have up to 34 characters even though 
you may not see all the characters in the Description field.

7. Keep the Maximum Length set to 0

8. Set pick list to the Preference: Existing 10’ Mjr – 2’ Minor

9. <D> the Apply then Close buttons.
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10. From the pull down menu Survey > Survey Data to Surface.  The Survey Data to 
Surface dialog will appear.

11. Pick from the list in the Surface Name 12345SURVSurface01 in the Surface Name field.

12. Set the Description to Use Style Description

13. Keep the Tolerance and Maximum Segment Length set to 0.00

14. Set the Curve Stroking Mode to Horizontal Only

15. Check Always Use: Style

16. Check Triangulate Surface

17. <D> the OK button the Survey Data to Surface dialog will close and the Triangulate 
Surface dialog will appear.
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18. Leave all settings unchecked. Maximum Length should be set to 0.00.

19. <D> the Apply button.  The Results section of the dialog should look similar to the image 
below. (Numbers may not match exactly)



20. <D> the More button. The Surface Properties dialog will appear.

21. Verify you are working with the correct surface 12345SURVSurface01.

22. Review the section for Data Range.  The Northing, Easting, and Elevation values should 
fall within the project limits.
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23. In the Data Range section, change the drop down selection to Random.

24. Review the Random point range.

Note: As part of your evaluation of the surface you are looking for a large error in the 
data such as a zero elevation, or truncated coordinates.

25. In the Data Range section, change the drop down selection to Breakline.

26. Review the Breakline point range.

Note: Having the flexibility to review our data by type can help when trying to track 
down errors in the DTM.
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27. On the Advanced tab choose Cross Sections - Symbology: T_Existing_Ground

28. On the Advanced tab choose Profiles - Symbology: T_Existing_Ground

29. <D> Apply then Close in the Surface Properties dialog.

30. <D> the Close button in the Triangulate Surface dialog.

31. Use the Workspace pane scroll arrows to view the Surfaces tab.

32. Verify 12345SURVSurface01 is the active surface. 

Note: You can change the active surface from the pull down menu 
Surface > Active Surface; highlight the surface name and <D> the Apply 
button.

33. From the pull-down File > Save > Surface.  The Save As dialog will appear with the 
Save as type set to Surfaces (*.dtm).
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34. Verify you are in the correct project directory. C:\Projects\12345\ROW_Survey\Working

35. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Surface name in the project folder matches the Surface 
name displayed in InRoads explorer will minimize any confusion.

36. <D> the Save then Cancel button.  The file will be saved to disk and the Save As dialog 
will close.
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Lab 7.2 - Correcting Crossing Segments

1. From the pull-down menu select, Surface > View Surface > Crossing Segments.  
The View Crossing Segments dialog will appear.

2. Verify from the Surface drop down 12345SURVSurface01 is selected.

3. <D> the Preferences… button.  The Preferences dialog will appear.

4. Select the CDOT preference

5. <D> the Load then Close buttons.

6. <D> the Apply button from the View Crossing Segments dialog.  The graphics X and O 
will be displayed and the Results button will be come active.
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7. <D> the Results button.  The Results report will appear locating all mismatched and 
crossing segments.

8. Review the results.

Note: This report can be saved to the design file or text file if needed.

9. <D> the Close button on the Results dialog.
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10. From the pull down menu, select Survey > Find Point in View

11. Find Point Name: 9622 Radius: 20

Note: The terrain breakline running left to right is crossing multiple other terrain 
breaklines.  In this particular situation a solution would be to break the terrain line 
using a Start control code.

12. <D> the Fieldbook    button from the Survey toolbar.  The survey Fieldbook Data  
dialog will appear.
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13. Locate point name 9631 in the fieldbook using the  Select Observation button from the 
Fieldbook Data dialog.

14. <R> the point name 9631 and select Edit from the shortcut menu or double click the point 
name.  The Edit Observation dialog will appear for point 9631

15. Type in the Code: 6001.00134 ST
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16. <D> the Apply then Close buttons.

17. Review your results dynamically from the fieldbook.  The terrain breakline was restarted 
so the breaklines are no longer crossing.

18. From the pull-down menu, select Survey > Find Point in View

19. Find Point Name: 14260 Radius: 20

Note: The terrain breakline is overlapping slightly where the line zig-zags.  In this 
particular situation a solution would be to edit the XY location of the point.14
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20. <D> the Fieldbook    button from the Survey toolbar.  The survey Fieldbook Data  
dialog will appear.

21. Locate point name 14260 in the fieldbook using the  Select Observation button from 
the Fieldbook Data dialog.

22. <R> the point name 14260 and select Edit from the shortcut menu or double click the 
point name.  The Edit Observation dialog will appear for point 14260

23. <D> the Target button.  The Edit Observation dialog will minimize allowing to select a 
point in the MicroStation view.

24. Using MicroStation snaps set the temporary snap to Nearest.

25. Hold down the Ctrl and Shift keys.  This will enable AccuSnap when using an InRoads 
command.
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26. Move the cursor to a point along the line string making sure the lines are not overlapping.

27. <D> a point in the MicroStation view to accept the point.  The Edit Observation dialog 
will reappear.  The new XYZ locations will be updated.

28. <D> the Apply then Close buttons.
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29. Review your results dynamically from the fieldbook.  The terrain breakline was restarted 
so the breaklines are no longer crossing.
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Lab 7.3 - Evaluate Surface Triangles

1. From the InRoads pull-down select, Surface > View Surface > Triangles.  The View 
Triangles dialog will appear.

2. Verify 12345SURVSurface01 is the active surface.

3. <D> the Preferences… button.  The Preferences dialog will appear.

4. Select the Existing preference.

5. <D> the Load then Close buttons.

6. <D> the Apply button.  The View Triangles dialog will minimize as the triangles are 
generated.  The dialog will reappear when it is finished.

7. <D> the Close button in the View Triangles dialog.
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8. Using MicroStation viewing commands Fit Active to review your results.

9. From the pull-down menu, select Survey > Find Point in View

10. Find Point Name: 1 Radius: 40
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11. Using MicroStation viewing commands Rotate View to review your results.

12. From the tool settings dialog select Method: Isometric

13. If you can not see all the triangles in the view.  Go to the MicroStation pull down 
Settings > View Attributes and check off Clip Back and Clip Front then Apply and 
exit the dialog.
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14. From the MicroStation pull down menu select, Utilities > Render > Filled Hidden Line.

15. Place a <D> in View 1

16. Review your results

[

Note: The tree feature code 3077 that was added to the fieldbook had the elevation 
incorrect.  The elevation error will be corrected back in the fieldbook.

17. Locate point name 1 in the fieldbook using the  Select Observation button from the 
Fieldbook Data dialog.

18. <R> the point name 1 and select Edit from the shortcut menu or double click the point 
name.  The Edit Observation dialog will appear for point 1.
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19. Key-in the Elevation: 6525.00

20. <D> the Apply then Close buttons.

21. From the View Survey toolbar toggle ON View Planimetrics   

22. Review your results.

Note: The fieldbook data is now correct when the fieldbook is re-exported the Survey 
data to Surface the surface data will be corrected also.

23. From the View Survey toolbar toggle OFF View Planimetrics   

24. In the MicroStation view border Rotate view to Top
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Lab 7.4 - Evaluate Surface Contours

1. From the InRoads pull-down select, Surface > View Surface > Contours.  The 
View Contours dialog will appear.

2. Verify 12345SURVSurface01 is the active surface.

3. <D> the Preferences… button.  The Preferences dialog will appear.

4. Select the Existing 10’ Mjr – 2’Minor preference.

5. <D> the Load then Close buttons.
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6. <D> the Apply button.  The View Contours dialog will minimize as the triangles are 
generated.  The dialog will reappear when it is finished.

7. <D> the Close button in the View Contours dialog.

8. Using MicroStation viewing commands Fit Active to review your results.

9. From the pull-down menu, select Survey > Find Point in View



Page 144 Colorado Department of Transportation

LAB 7 - DTM Evaluation Labs for Using InRoads Survey for Data Reduction

10. Find Point Name: 20005 Radius: 40

 

Note: There is a problem with a random point in the roadway.  The test hole location that 
were imported with the import wizard has a busted elevation.

11. Locate point name 20005 in the fieldbook using the 
  Select Observation button from the Fieldbook Data dialog.

12. <R> the point name 20005 and select Edit from the shortcut menu or double click the 
point name.  The Edit Observation dialog will appear for point 20005.
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13. Key-in the Elevation: 6581.51

14. <D> the Apply then Close buttons.  The elevation will be corrected for the final DTM 
export.
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15. From the pull-down menu, select Survey > Find Point in View

16. Find Point Name: 8000 Radius: 40

 

Note: There is a problem with the breakline.  The breakline has a bust in the rod height.

17. Locate point name 8000 in the fieldbook using the 
  Select Observation button from the Fieldbook Data dialog.

18. <D> the point name 8000 then hold down the Shift key and select point name 8002.  
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19. <R> the selected list and select Edit from the shortcut menu.  The Edit Observation dialog 
will appear.

Note: The target height is the only field that can be edited because it has the same value 
for all 3 points.

20. Key-in the Target Height: 13.27

21. <D> the Apply then Close buttons.  The elevation will be corrected for the final DTM 
export.

Note: The fieldbook data is now correct when the fieldbook is re-exported the Survey 
data to Surface the surface data will be corrected also.

22. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.
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Lab 7.5 - Multipoint Profile as Section check

1. From the pull-down menu, select Survey > Find Point in View

2. Find Point Name: 13121 Radius: 160

Note: Using the Multipoint Profile command will be used to evaluate key areas such as 
this culvert crossings.

3. Using MicroStation Level Display, Turn OFF all Terrain levels as shown above.

4. From the pull down menu select, Tools > Global Scale Factors…  The Scale Factors 
dialog will appear.

5. If Global Scale Factors is not an option go to the InRoads pull down menu and select:
Tools > Application Add-Ins > Global Scale Factors Add-In

6. <D> the Lock button.  The button display will change showing as unlocked.

7. Key-in scale Cell: 1

8. <D> the Apply then Close buttons.
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9. From the pull down menu select, Evaluation > Profile > Create Profile.  The Create 
Profile dialog will appear.

10. <D> the Preferences… button.  The Preferences dialog will appear.

11. Select the preference name 5x Vertical

12. <D> the Load then Close buttons.
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13. On the General leaf key in Set Name: DTM Chk1

14. Verify 12345SURVSurface01is checked in the Surfaces section.

15. <D> the Include leaf.

16. Check ON the Crossing Features box.

17. Check ON the Display Planimetrics box.
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18. <D> the Controls > Limits leaf.

19. Check Off the Window Clearance Apply box.

20. <D> the Apply button.  The dialog will minimize allowing you to select points in the 
MicroStation view.
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21. <D> a point in the MicroStation view at the north end of the and center of the road.

♦ There is no need to hold down on the Left mouse button.

22. Move the cursor, a line will begin to generate

23. <D> a second point perpendicular across the roadway crossing the culvert, as shown 
above.

24. <R> to quit defining profile extraction vertices.

25. <D> a location in the MicroStation view to draw the profile.  The Create Profile dialog 
will reappear and the Profile is generated in the view.

26. Review your results.

27. Continue to Create Profiles at key locations.

♦ Culvert Crossings

♦ Driveway Entrances

♦ Centerlines

When finished:

28. Using MicroStation Delete button.  Delete all DTM Check profiles.

29. Save the Survey fieldbook.  From the Workspace Bar <R> on 12345SURVFieldbook01 
select Save from the shortcut menu.
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Lab 8.1 - Exporting Survey Data to Graphics

Managing Drawings in the Reference Files folder

The files in the Reference Files folder are for other disciplines to reference.  Other disciplines 
are to reference in the 01 model file.  There are already 01 files in the Reference Files folder 
that are out of date.  The new Survey Fieldbook that is exported will become the new 01 file.

Section Objectives:

♦ Create a new design file to write survey data to graphics.

♦ Run the CDOT Stratify Survey tool from the CDOT Menu.

1. Open Windows Explorer.

2. Navigate to the folder C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

3. Rename each file 12345SURV_Topo* with a 01 counter and rename it to 02.

Note: The next steps will create these model files with an updated InRoads Survey fieldbook.



Page 154 Colorado Department of Transportation

LAB 8 - Exporting the Fieldbook Labs for Using InRoads Survey for Data Reduction

Creating new 01 design files.

4. From the MicroStation pull down menu select File > Open the Open dialog will appear.

5. In the MicroStation Manager dialog path to the directory: 
C:\Projects\12345\ROW_Survey\Drawings\Reference_Files\

6. Select the file 12345SURV_Topo##Scale##.dgn from the Open dialog.

Note: The purpose of the files with “##” symbols are for creating new files with the correct 
naming convention.

7. <D> the Open button MicroStation Manager dialog will close and open the file.

8. From the MicroStation pull down menu select File > Save As the Save As dialog will 
appear.
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9. Replace the ## symbols with 100 scale and 01 model. 
Type in File name: 12345SURV_Topo100Scale01.dgn

10. <D> the Save button the Save As dialog will close and MicroStation will open the file 
12345SURV_Topo100Scale01.dgn

11. Verify the 12345SURVFieldbook01 survey fieldbook is active.  You can tell which 
fieldbook is active by the red box around the fieldbook button.
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12. To modify the scale as it relates to cells, text, and linestyles go to 
Tools > Survey Options > [General]. The Survey Options dialog will appear.

13. Set the Scales for Cell, Text, and Line as shown below.

♦ Cell Scale:100
♦ Text Scale:20
♦ Line Scale:100

Note: Segregate Text by Feature Level, should be checked on, this will save the symbols, 
point names, codes, notes, errors, and elevations to the same level as the survey feature.

14. <D> the OK button the Survey Options dialog will close.
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15. From the InRoads pull down menu select, Survey > View Survey Data > Write 
Survey Data to Graphics… the Write Survey Data to Graphics dialog will open.

Note: By default if you had dynamic graphics still toggled on, those same components would 
be toggled on in the Write Survey Data to Graphics dialog.

16. Check ON the Select All box.

17. From the drop down list for Curve Stroking: Horizontal Only

18. <D> the Apply then Close button. The Survey fieldbook planimetrics has been written to 
graphics.

19. Verify all View Survey Data buttons are toggled display off.
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20. From the MicroStation view border Fit the design file.

21. Review your results.

22. From the CDOT Menu pull-down select CDOT Tools > Stratify Survey.  The 
Stratify Survey dialog will appear.

23. Type in the Scale: 20

Note:

♦ Under Existing Files, the Append option will add or merge the new data into an 
existing file. A new file will be created if the file does not already exist.

♦ Under Existing Files, the Overwrite All option will create a new file, deleting any 
previously existing file.

♦ Under Existing Files, the Overwrite None option will disable the processing option for 
a file if the file already exists.

♦ The Process option Adjust Planimetrics will resize the planimetrics text (if necessary) 
and convert the grouped text strings to view independent cells in order to allow for 
viewing this text in any 3D view.

24. Verify the JPC, Scale, and Sheet Number entries are correct.  Altering any of those values 
will automatically alter the output file names.  If the Attach check box in the Contours 
section is grayed out, the contour file does not exist.  You may edit the name specified in 
the File Name field to enter the name of an existing contour file.

25. <D> OK button to start the process.
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26. As the data is being moved to the appropriate reference file a Processing Status dialog 
provides an update on the progress.  You may Cancel at any time to stop the processing, if 
necessary.

27. When completed, a Processing Completed message is displayed.  <D> OK to exit the 
program.

28. The fieldbook data has now been stratified into separate reference files. The planimetrics 
will be in the master design file with all of the symbols, names, codes, etc., attached as 
reference files. To view these attachments select File > Reference from the MicroStation 
pull down menu.
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Lab 8.2 - Exporting Survey Data to Surface

Managing Drawings in the Reference Files folder

The files in the Reference Files folder are for other disciplines to reference.  Other disciplines 
are to reference in the contour model file.  There is already a contour file in the Reference Files 
folder that is out of date.  The new Survey Fieldbook that is exported will become the new 
contour file.

Section Objectives:

♦ Create a new design file to create the surface display graphics.

♦ Export the survey data to a surface file for a final deliverable.

♦ Use the delete triangle command to constrain the triangles to the survey points 
collected in the field.

♦ View the new surface perimeter.

♦ Import new perimeter into the surface as an exterior boundary.

1. From the MicroStation pull down menu select File > New.  The New dialog will appear.

2. Navigate to the file folder Reference_Files by double clicking the directory folders.

3. At the bottom of the dialog box verify that the seed file is set to Roadway_Design_3D.dgn.

4. Key in the file to be created 12345SURVContour100Scale2_10.dgn

5. <D> the OK button in the New dialog.  The New dialog will close and the file 
12345SURVContour100Scale2_10.dgn  will open.

6.  From the MicroStation menu pull down select Settings > Drawing Scale the Drawing 
Scale dialog will appear.
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7. In the Annotation drop down list select 1” = 1’

8. From the MicroStation pull down menu select File > Save Settings.

Note: The reason annotation scale needs to be set to 1”=1’ is so that the linestyles will be 
displayed correctly from InRoads Survey.

9. Verify the 12345SURVFieldbook01 fieldbook is active.  You can tell which fieldbook is 
active by the red box around the fieldbook button.

Survey Data to Surface

10. From the InRoads pull down menu, select File > New.  The New dialog will appear.

11. <D> the Surface tab.

12. From the drop down list select Type: Existing

13. Key in the surface Name: 12345SURVSurface01

14. Key in the Description: CDOT Surface Final

Note: Key in any additional file information in the Description field of the dialog, such as 
Date, User, and Design file name. You have up to 34 characters even though you may 
not see all the characters in the Description field.

15. Keep the Maximum Length set to 0

16. From the drop down list Preference: Existing 10’ Mjr – 2’ Minor

17. <D> the Apply then Close buttons.
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18. From the pull down menu Survey > Survey Data to Surface.  The 
Survey Data to Surface dialog will appear.

19. From the drop down list Surface Name: 12345SURVSurface01 

20. Type in the Parent Name: Survey Fieldbook Export

21. From the drop down list Description: Use Style Description

22. Keep the Tolerance and Maximum Segment Length set to 0.00

23. From the drop down list Curve Stroking Mode: Horizontal Only

24. Check ON Always Use: Style

25. Check ON Triangulate Surface

26. <D> the OK button the Triangulate Surface dialog will appear.
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27. Leave all settings unchecked. Maximum Length should be set to 0.00.

28. <D> the Apply button.  The Results section of the dialog should look similar to the image 
below.

29. <D> the More button. The Surface Properties dialog will appear.

30. Verify you are working with the correct surface 12345SURVSurface01.

31. Review the section for Data Range. The Northing, Easting, and Elevation values should 
fall within the project limits.
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32. On the Advanced tab choose 
Cross Sections - Symbology: T_Existing_Ground

33. On the Advanced tab choose 
Profiles - Symbology: T_Existing_Ground

34. <D> Apply then Close in the Surface Properties dialog.

35. <D> the Close button in the Triangulate Surface dialog.

36. Use the Workspace bar scroll arrows to view the Surfaces tab.

37. Verify 12345SURVSurface01 is the active surface.

Note: You can change the active surface from the pull-down menu Surface > Active Surface; 
highlight the surface name and <D> the Apply button.
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38. From the InRoads pull down File > Save > Surface.  The Save As dialog will appear 
with the Save as type: Surfaces (*.dtm).

39. Verify you are in the correct project directory.
C:\Projects\12345\ROW_Survey\InRoads\DTM

40. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Surface name in the project folder matches the Surface name 
displayed in InRoads explorer will minimize any confusion.

41. <D> the Save then Cancel button.  The file will be saved to disk and the Save As dialog 
will close. 
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Lab 8.3 - Exterior Boundary

Errant triangles can be eliminated by controlling the maximum triangle length. However this 
can cause problems in areas of the DTM where data density varies. A more refined method is to 
add an exterior boundary that constrains the triangles to fall within the limit of the exterior 
boundary.

Section Objectives:

♦ Delete unwanted triangles from the design file.

♦ Display the perimeter of the model (active triangle limits).

♦ Import the displayed perimeter into the DTM as an exterior feature.

♦ Verify the results.

1. Open the MicroStation file - 12345SURVContour100Scale2_10.dgn

2. Open the InRoads Survey Fieldbook file - 12345SURVFieldbook01.fwd

3. Open the InRoads Survey Surface file - 12345SURVSurface01.dtm

4. Using MicroStation Delete.  Delete all graphics from the design file.

5. Using MicroStation Window Area button center the survey fieldbook dynamic display 
planimetric graphics to View 1 Top rotation.

6. From the pull down menu select, Surface > View Surface > Perimeter.  The 
View Perimeter dialog will appear.

7. <D> the Preferences… button.  The Preferences dialog will appear.

8. Select CDOT from the Preferences dialog

9. <D> the Load then Close buttons in the Preferences dialog.

10. <D> the Apply button in the View Perimeter dialog.
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11. Review your results.

12. Close the View Perimeter dialog.

Note: The perimeter will be used as a reference line as triangles are deleted.

13. Redisplay the triangles Surface > View Surface > Triangles.  The View Triangles 
dialog will appear.

14. Load the Existing Preferece for View Triangles.

15. <D> the Apply button in the View Triangles dialog.

16. From the InRoads pull down menu select, Surface > Edit Surface > Delete Triangles.  
The Delete Triangle dialog will appear.

17. <D> the Apply button.  The Delete Triangle dialog will minimize allowing you to select a 
point in the view.
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18. <D> a point in the MicroStation view off to the side of the surface limits.

♦ There is no need to hold down on the Left mouse button.

19. Move the cursor, a line will be displayed

20. Sweep the cursor over the surface model to dynamically highlight surface triangles

Note: The line highlights triangles as they are crossed. Highlighted triangles will be removed 
from the surface model once a data point <D> is given to establish the endpoint of the 
line (selection). 

21. <D> a second point to define the line at the point shown above.

22. <D> a point in the view to accept and delete the triangles.

23. Continue drawing lines to remove undesirable triangles from other areas of the surface.

24. <R> when you have completed deleting triangles from this zoom ratio.  The Delete 
Triangle dialog will reappear.

Note: You can write triangles to the display as MicroStation graphics at any time. Do not re-
triangulate the surface before defining an exterior boundary as deleted triangles will be 
re-established. 

Note: If the triangles are redisplayed, keep in mind, displayed triangles are a reflection of 
what InRoads has in memory at a specific point in time. If triangles are deleted (from 
memory) the MicroStation graphics displayed will not reflect this change until the 
triangles written to graphics are redisplayed (refreshed).
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25. Use MicroStation to view Window into an area of the survey.

26. From the View Survey toolbar toggle display ON for Symbols 

♦ If your symbols are not displaying make sure the level is turned on.

Note: Triangles should only span between known (collected) points. The above graphic 
shows a group of triangles that should be eliminated.

27. Continue to Pan along the file and deleting triangles.  Don’t be concerned that the model 
may not be perfect for this training.

When you have finished:

28. <D> the Close button in the Delete Triangle dialog.

29. From the View Survey toolbar toggle display OFF for Symbols 
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30. Redisplay the perimeter Surface > View Surface > Perimeter.  The View Perimeter 
dialog will appear.

31. <D> the Apply button in the View Perimeter dialog.

32. Review your results.

Note: This closed shape represents the edge of the surface (triangles) spatially correct 
(location and elevation). Importing this shape into the DTM will act as an exterior 
boundary to constrain the triangulation process.

33. From the InRoads pull down menu select, File > Import > Surface.  The Import Surface 
dialog will appear.
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34. Set the following dialog items:

♦ Surface: 12345SURVSurface01

♦ Load From: Single Element
♦ Elevations: Use Element Elevations
♦ Key-in Seed Name: Exterior1
♦ Feature Style: T_Exterior Boundary
♦ Point Type: Exterior

35. <D> the Apply button.  The Import Surface dialog will minimize allowing you to select 
the perimeter element.

36. <D> on the surface Perimeter graphics displayed in MicroStation View 1.

37. <D> again to accept this element.  The Import Surface dialog will reappear.

38. <D> the Close button in the Import Surface dialog.
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39. From the pull down menu select, Surface > Triangulate Surface. The 
Triangulate Surface dialog will appear.

40. <D> the Apply button in the Triangulate Surface dialog.
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41. <D> the More button on the Triangulate Surface dialog.  The Surface Properties dialog 
will appear.

42. Review your results.

Note: The surface now has Exterior point data, your numbers will not match exactly.

43. <D> the Close button in the Surface Properties dialog.

44. <D> the Close button in the Triangulate Surface dialog.
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45. Redisplay the triangles Surface > View Surface > Triangles.  The View Triangles 
dialog will appear.

46. <D> the Apply button in the View Triangles dialog.

47. Review your results.

48. In the Workspace bar Surface tab <R> on 12345SURVSurface01 select Save from the 
shortcut menu.
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Contour Files

Contour information will be saved to separate files for ease of referencing and level control.  
Each scale and contour interval will have a unique name.

49. From the pull-down menu select, Tools > Options.  The InRoads Options dialog will 
appear.

50. <D> the Factors tab.

Note: The values shown here will be applied to all commands that display text, cells, or 
linestyles.

51. Verify the Scale Factors 

♦ Text: 20
♦ Cell: 100
♦ Linestyle:  100

52. <D> the Apply then Close buttons.
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53. From the pull-down menu select, Surface > View Surface > Contours.  The 
View Contours dialog will appear.

54. Verify the active Surface: 12345SURVSurface01

55. <D> the Preferences button.

56. Select the preference Existing 10’ Mjr – 2’ Minor

57. <D> the Load then Close buttons.
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58.   <D> the Apply button.  The View Contours dialog will temporarily minimize as the 
surface is processed and the contours are generated the dialog will reappear when the 
contours have been generated.

59.   Review your results.
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Lab 8.4 - Exporting Survey Data to Geometry - FINAL

Section Objectives:

♦ Export survey data to a Geometry Project for a final deliverable.

1. Verify the 12345SURVFieldbook01 fieldbook you want to export is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button.

2. From the InRoads pull down menu, select File > New.  The New dialog will appear.

3. Select the Geometry tab.

4. From the type pick list verify the Type: Geometry Project

5. Key in the geometry Name: 12345SURVGeometry01

6. Key in the Description: CDOT Geometry Final

Note: Key in any additional file information in the Description field of the dialog, such as 
Date, User, and Design file name. You have up to 34 characters even though you may 
not see all the characters in the Description field.
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7. <D> the Apply and Close buttons.

8. From the InRoads pull down menu, select Survey > Survey Data to Geometry.  The 
Survey Data to Geometry dialog will appear.

9. From the drop down list select Project Name: 12345SURVGeometry01

10. Set the Description: Use Style Description

11. Set the Curve Stroking: Horizontal Only

12. <D> the Apply then Close button.
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13. Use the Workspace pane scroll arrows to view the Geometry tab.

14. Verify 12345SURVGeometry01 is the active Geometry Project.

15. From the InRoads pull down select File > Save > Geometry Project.  The Save As 
dialog will appear with the Save as type: Geometry (*.alg).

16. Verify you are in the correct project directory. 
C:\Projects\12345\ROW_Survey\InRoads\Geometry

17. The file name should match the Active name at the bottom of the Save As dialog.  If 
necessary, use the drop-down arrow in the Active field and reselect the desired name to 
ensure the saved file name will match the surface name.

Note: Ensuring that the saved Geometry name in the project folder matches the Geometry 
name displayed in InRoads explorer will minimize any confusion.

18. <D> the Save and then the Cancel button.  The file will be saved to disk and the Save As 
dialog will close.
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Lab 8.5 - Saving an InRoads Project file RWK

Project file stores the location of multiple InRoads files.  RWK files allow the user to open just 
one RWK which could load a survey, surface, and geometry project.  The RWK can be opened 
and edited in Notepad incase there are changes in the directory structure.

Section Objectives:

♦ Create a new Project file that will autoload the survey fieldbook file and final 
deliverable.

1.  From the pull down menu, select File > Save > Project.  The Save As dialog will appear.

2. Key-in the File name: 12345Project.rwk

3. <D> the Options… button.  The Project Options dialog will appear.
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4. From the Surfaces tab check the Add and Update boxes for Surface Name 
12345SURVSurface01.

5. From the Geometry Project tab check the Add and Update boxes for Geometry Name 
12345SURVGeometry01.

6. From the Survey tab check only the Add box for Survey Name 12345SURVFieldbook01.
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Note: By only selecting the Add check box for the Survey tab the file will act as read only 
when opened and saved with the RWK file in the future.

7. <D> the OK button.  The Project Options dialog will close.

8. <D> the Save then Cancel buttons.  The Save As dialog will close.
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Lab 8.6 - Directory Clean up

1. Open Windows Explorer Windows + E

2. Navigate to the folder C:\Projects\12345\ROW_Survey\Working

3. Delete any old or duplicated files for the Working directory.

Section Summary:
♦ In Lab 8.1 -Exporting Survey Data to Graphics the survey fieldbook was exported to 

graphics including the point names, codes, etc.  The file was then stratified using the 
custom application CDOT Stratify Survey to create multiple survey files and reference 
the files appropriately.

♦ In Lab 8.2 -Exporting Survey Data to Surface the survey fieldbook was exported to the 
final surface file.  

♦ In Lab 8.3 -Exterior Boundary the surface was then cleaned up by deleting errant 
triangles and a new exterior boundary was created.

♦ In Lab 8.4 -Exporting Survey Data to Geometry - FINAL the survey fieldbook file was 
exported as a final geometry project.

♦ In Lab 8.5 -Saving an InRoads Project file RWK the final deliverable survey files were 
used to create a Project file to help the user load multiple files.

♦ In Lab 8.6 -Directory Clean up the working directory was cleaned up to make sure all 
files that were no longer needed were removed from the folder.
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Lab 9.1 - Locks

Section Objectives:

♦ View surface triangles using Pencil lock with different Preferences.

Locks Toolbar

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Verify both the Feature Filter Lock    and Style Lock    are toggled OFF.  The Locks 
are toggled OFF when the button appears darker.

4. From the InRoads pull down menu select, 
Surface > View Surface > Triangles.  The View Triangles dialog will appear.

5. <D> the Apply button.  The View Triangles dialog will minimize as the triangles are 
generated.  The dialog will reappear when it is finished.

Note: The triangles displayed are not using the correct element attributes for color and 
level.  Using the Pencil mode will erase the current displayed triangles and 
redisplay the correct element attributes for existing triangles.

6. <D> the Preferences… button.  The Preferences dialog will appear.
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7. Select the Existing preference.

8. <D> the Load then Close buttons.

9. <D> the Apply button.

Note: Notice how the old triangles are “erased” and the new triangles are redrawn using 
the loaded existing preference.

Section Summary:
♦ In this lab we viewed surface triangles using Pencil lock with different Preferences.

Lab 9.2 - Advanced Locks

Section Objectives:

♦ In this lab the difference between Pencil and Pen lock will be shown.

These are only generalized steps to guide you.  Ask your instructor if you have any questions.

1. Using MicroStation Delete.  Delete all triangles from the DGN file.

2. Toggle the Write lock from Pencil    mode to Pen    mode.

3. Display the triangles using Preference Existing.
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4. Redisplay the triangles using Preference Proposed.

Note: You should end up with two sets of triangles.  Pen mode can be used for other 
display operations such as perimeter and contours.
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When you have finished:

5. Using MicroStation Delete button.  Delete all triangles from the DGN file.

6. From the MicroStation pull down menu select, 
File > Compress > Design

7. Verify your Locks toolbar is set back to Pencil    mode.

Section Summary:
♦ In this lab Pen lock was demonstrated using View Triangles command.
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Lab 9.3 - Global Scale Factor

InRoads annotation (text, cells, and linestyles) is controlled with configurable scale settings. In 
the case of contour labeling, text size is driven by 2 factors.  The text size specified in the 
View Contours dialog box and the active settings (multiplier) defined through the use of a 
Global Scale Factor.

Section Objectives:

♦ In this lab the text scale factor will be changed to show how to modify text sizes when 
displaying contour labels.

♦ In this lab the Global Scale factor Add-in will be added to the Tools pull down menu 
for easier access to the scales.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. From the pull-down menu select, Tools > Options.  The InRoads Options dialog will 
appear.
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4. <D> the Factors tab.

Note: The values shown here will be applied to all commands that display text, cells, or 
line styles.
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5. Set the Text, Cell and Line Style Scale Factors to 100

6. <D> the Apply then Close buttons.

7. From the pull-down menu select, 
Surface > View Surface > Contours.  The View Contours dialog will appear.

8. Verify the active Surface: 12345SURVSurface01

9. Load the CDOT Preference
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10. <D> the Apply button.  The View Contours dialog will temporarily minimize as the 
surface is processed and the contours are generated the dialog will reappear when the 
contours have been generated.

11. Review your results.
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12. From the pull-down menu select, Tools > Options.  The InRoads Options dialog will 
appear.

13. <D> the Factors tab.

14. Set the Text, Cell and Line Style Scale Factors to 50

15. <D> the Apply then Close buttons.
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16. <D> the Apply button in the View Contours dialog.  Notice the change in the annotation 
size.

The Global Scale Factor dialog is frequently used. It can be added to the interface for easy 
access.

17. From the pull down menu select, Tools > Application Add-Ins, the 
Applications Add-ins dialog will appear.

18. Check ON Global Scale Factor Add-In.

Note: The Description section of the dialog will give details where to find the added 
command in the pull down menus.
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19. <D> the OK button.  The Application Add-ins dialog will close.

20. From the pull down menu select, Tools > Global Scale Factors...  The Global Scale 
Factors dialog will appear.

Note: The Scale Factors dialog can remain open saving space and time.

21. Key-in the Text, Cell, and Line Style Scale Factors dialog to 100

22. <D> the Apply button.

Section Summary:
♦ In this lab the text scale factor was changed to show how to modify text sizes when 

displaying contour labels.

♦ In this lab the Global Scale factor Add-in was added to the Tools pull down menu for 
easier access to the scales.
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Lab 9.4 - View Surface Display Constrained

Most surface display commands have the option to display within the limits of a fence place in 
a MicroStation model.

Section Objectives:

♦ In this lab a MicroStation fence will be placed in the file to constrain the triangles 
inside the fence.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. From the InRoads pull down menu select, Surface > Update 3-D/Plan Surface 
Display.  The Update 3-D/Plan Surface Display dialog will appear.

4. Select the Mode: Display On radio button.

5. Verify 12345SURVSurface01 is the active surface.

6. Check ON Perimeter box.

7. Check ON Contours box.

8. <D> the Apply buttons.  The Contours and Perimeter graphics will be displayed to the 
design file.
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9. Using MicroStation view commands window into a portion of the surface.

10. From the MicroStation Main toolbar <D> the Place Fence button.

11. From the Tool Settings dialog select Fence Type: From View

12. <D> a point in View 1.  The Fence will appear around the edge of the view border.
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13. From the InRoads pull down menu select, Surface > Update 3-D/Plan Surface 
Display.  The Update 3-D/Plan Surface Display dialog will appear.

Note: Notice this time Fence Mode became active and the mode is set to Inside.

14. <D> the Apply button.  The triangles will display inside the fence.

15. Using MicroStation view commands zoom out from the triangles and review your result

16. <D> the Close button in the Update 3-D/Plan Surface Display dialog.
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Section Summary:
♦ In this lab a MicroStation fence was be placed in the file to constrain the triangles 

inside the fence.
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Lab 9.5 - View Contour Settings

Section Objectives:

♦ Use different Preferences will be used to display contours.

♦ Change settings in the Advanced tab of the View Contours dialog to view contours 
smooth or between an elevation range.

♦ Change settings in the Labels tab of the View Contours dialog to view contour labels at 
different intervals and display options.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Using MicroStation Delete button.  Delete all Contours in the drawing.

4. From the pull-down Surface > View Surface > Contours.  The View Contours dialog 
will appear.

5. Verify the active Surface: 12345SURV_Surface_Existing
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6. <D> the Preferences… button.  The Preferences dialog will appear.

7. Select the preference Existing 10’Mjr – 2’ Minor.

8. <D> the Load then Close buttons.

Note: Notice the change in the Interval and Minors per Major settings.

9. <D> the Apply button.
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10. Review your results.

11. <D> the Advanced tab in the View Contours dialog.

12. Check OFF Smooth in the View Contours dialog.

13. <D> the Apply button and review your results.

14. Check ON Elevation in the View Contours dialog.

15. Set the Elevation High and Low values that will work with the loaded surface.

16. <D> the Apply button and review your results.



Colorado Department of Transportation   Page 203

A Practical Guide for Using InRoads XM LAB 9 - Additional Exercises

17. <D> the Labels tab in the View Contours dialog.

18. Continue to display contours using different settings in the 
Major Labels and Minor Labels sections.

♦ Precision

♦ Orientation

♦ Spacing

♦ Prefix

♦ Suffix

Note: Ask your instructor if you have a question on any of these settings.

When you have finished:

19. Reload the Preference Existing 10’Mjr – 2’ Minor.

20. Redisplay the contours.

Section Summary:
♦ In this lab different Preferences were used to display contours.

♦ In this lab changes in the Advanced tab were made to view contours smooth or 
displayed between an elevation range defined by the user.

♦ In this lab change settings in the Labels tab were made to view contour labels at 
different intervals and display options.
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Lab 9.6 -  Profiles from existing alignments

Section Objectives:

♦ Create a Profile from an existing horizontal alignment to create a profile to help 
evaluate the existing surface.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Open an InRoads Geometry Project.

InRoads Survey only allows for multipoint profiles.  To create profiles from an existing 
alignment InRoads needs to be added.

4. From the InRoads pull down menu select Tools > Product Add-ins.  The 
Product Add-ins dialog will appear.

5. Select the Bentley InRoads XM Edition application and select the OK button.  InRoads 
application will be added to the InRoads Survey interface.

6. From the InRoads pull down menu select 
Geometry > Active Geometry.  The Active Geometry dialog will appear.

7. Select the Type: Horizontal Alignment
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8. <D> the Target    button.  The Active Geometry dialog will minimize allowing you to 
select the centerline in the MicroStation view.

9. <D> the centerline of the road.  The centerline of road will highlight and the Active 
Geometry dialog will reappear.

10. <D> the Apply then Close buttons.  The Horizontal Alignment name will be active.

11. From the InRoads pull down menu select, Geometry > Fit Alignment.

12. <R> for the active alignment in the MicroStation View.

13. From the pull down menu select, Geometry > View Geometry > Active Horizontal

Note: The above graphic is where the profile will be extracted.

14. From the pull down menu select, Tools > Global Scale Factors…  The Scale Factors 
dialog will appear.
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15. Key-in the scale factor 100

16. <D> the Apply then Close buttons.

17. From the InRoads pull down menu select Evaluation > Profile > Create Profile.  The 
Create Profile dialog will appear.

18. <D> the Preferences… button.  The Preferences dialog will appear.

19. Select the preference name 5x Vertical.

20. <D> the Load then Close buttons.
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21. On the Create Profile dialog Create Profile > General leaf 
Set Name: DTM Chk Alignment

22. Verify 12345SURV_Surface_Existing is checked in the Surfaces section.

23. On the Create Profile dialog Create Profile > Source leaf.

24. Set the Radio button to Alignment

25. <D> the Apply button.  The dialog will minimize allowing you to select the location of the 
profile in the MicroStation view.

26. <D> a location in the MicroStation view to draw the profile.  The Create Profile dialog 
will reappear and the Profile is generated.
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27. Review your results.

28. Continue to generate profiles along the remainder of the centerline.

When finished:

29. Using MicroStation Delete button.  Delete all DTM Check profiles.

Section Summary:
♦ In this lab a profile was created from an existing horizontal alignment to help evaluate 

the existing surface.
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Lab 9.7 - Cross Sections

Section Objectives:

♦ Create a Cross Section set from an existing horizontal alignment to help evaluate the 
existing surface.

1. Open a new working MicroStation model file.

2. Open an InRoads Surface.

3. Open an InRoads Geometry Project.

InRoads Survey only allows for multipoint profiles.  To create profiles from an existing 
alignment InRoads needs to be added.

4. From the InRoads pull down menu select Tools > Product Add-ins.  The 
Product Add-ins dialog will appear.

5. Select the Bentley InRoads XM Edition application and select the OK button.  InRoads 
application will be added to the InRoads Survey interface.

6. From the InRoads pull down menu select 
Geometry > Active Geometry.  The Active Geometry dialog will appear.

7. Select the Type: Horizontal Alignment
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8. <D> the Target    button.  The Active Geometry dialog will minimize allowing you to 
select the centerline in the MicroStation view.

9. <D> the centerline of the road.  The centerline of road will highlight and the Active 
Geometry dialog will reappear.

10. <D> the Apply then Close buttons.  The Horizontal Alignment name will be active.

11. From the InRoads pull down menu select, Geometry > Fit Alignment.

12. <R> for the active alignment in the MicroStation View.

13. From the pull down menu select, Geometry > View Geometry > Active Horizontal

Note: The above graphic is where the profile will be extracted.

14. From the pull down menu select, Tools > Global Scale Factors…  The Scale Factors 
dialog will appear.
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15. Key-in the scale factor 50

16. <D> the Apply then Close buttons.

17. On the Create Cross Section dialog Create Cross Section > General leaf 
Set Name: DTM Chk Alignment

18. Verify 12345SURV_Surface_Existing is checked in the Surfaces section.

19. On the Create Cross Section dialog Create Cross Section > Source leaf.
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20. Set the Radio button to Alignment.

21. <D> the Apply button.  The dialog will minimize allowing you to select the location of the 
profile in the MicroStation view.

22. <D> a location in the MicroStation view to draw the profile.  The Create Cross Section 
dialog will reappear and the cross sections will be generated.

23. Review your results.

Section Summary:
♦ In this lab a cross section set was created from an existing horizontal alignment to help 

evaluate the existing surface.
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Lab 9.8 - Survey

Survey Feature Filters

The geometry project 12345SURVGeometry01 contains horizontal and vertical alignments for 
every linear item that was surveyed. Additionally the Cogo buffer contains points for every 
survey shot collected.  While this may be desirable information, often it is desirable to work 
with a subset of the survey information such as pavement center lines, control lines, or other 
specific entities. Working with a subset of the information increases efficiency by working with 
a smaller data set and freeing-up additional computer memory for other operations. This can be 
accomplished by using Survey Feature Filters when exporting survey data (Fieldbook) to a 
geometry project.

Section Objectives:

♦ The goal is to have a geometry project that contains only the information important to 
establishing the centerline of the existing road.

♦ The use of survey style filters will assist in sorting the data.

1. Open a new working MicroStation design file.

2. Open an InRoads Survey Fieldbook.

3. From the pull down menu select Survey > Survey Style Filter.  The 
Survey Style Filter dialog will appear.
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4. Toggle the radio button Start With: None

5. Select Properties: Numeric Code

6. Key-in the Value: 1316

7. Toggle the radio button Mode: Include

8. <D> the Add Rule button.  The rule will be added to the Rules List.

9. Add additional numeric rules for:

♦ 1318
♦ 1319
♦ 1320
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10. Select Properties: Alpha Code

11. Key-in the Value: 10*

12. Toggle the radio button Mode: Include

13. <D> the Add Rule button.  The rule will be added to the Rules List.

14. <D> the Save As button.  The Save Filter As dialog will appear.

15. Key-in the Name: Survey Keypoints

16. <D> the OK button in the Save Filter As dialog.
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17. <D> the OK button.  The Survey Feature Filter dialog will close.

Note: The Survey Feature Filter just built is for filtering information contained in a 
Survey Fieldbook and gets saved in the Survey Feature Table (fwf) file vs. in the 
InRoads Civil.ini file as Feature Filters do. Therefore, it gets applied within the 
Fieldbook and not in the InRoads Feature Filter interface. However the Filter Lock 
needs to be turned on in the InRoads Locks toolbar for it to be active.

18. On the Locks toolbar, toggle ON the Feature Filter Lock
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Note: Notice that 2 things happen, the Fieldbook Data dialog will update to display only 
the data that passes the filter. Also the MicroStation display will only display 
survey data that passes the filter.

Section Summary:
♦ In this lab a survey style filter was created to only export data from the fieldbook to a 

Geometry Project that pertained to reestablishing the mainline.
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Lab 9.9 - Importing multiple files

To speed up the process of importing multiple files you can create a Group file. This.is a simple 
text file that points to the file location and import wizard to use.    When it is available these are 
the steps for using Group Files on import.

Section Objectives:

♦ Import multiple Sokkia SDR files as one into InRoads Survey using a Group of files 
ASCII file.

1. From the pull-down menu, select File > Import > Survey Data.  The Import dialog will 
open.

2. Change the drop-down arrow Files of type: Group of Files (*.*)

3. Path to the folder C:\Projects\12345\ROW_Survey\Survey\Raw_Data

4. Select the file LoadSDR_files.txt from the unfiltered list of files.

♦ The Group of files option is a handy way to load multiple files at one time.  The file is 
a simple ASCII text file that shows the file location and import type.  Below is a screen 
shot of the file opened in Notepad.  This file would need to be created prior to using it 
on a different project.

5. In the Import dialog <D> the Import button.

6. <D> the Close button.  All the files listed in the text file will be imported.

Section Summary:
♦ In this lab a Group of SDR files were imported at one time using an existing ASCII.
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Lab 9.10 - Metric Survey Data to Imperial Survey Data

Section Objectives:

♦ To convert an existing InRoads Survey fieldbook file units from Metric to US Feet.

1. Open a new working MicroStation model file.

2. Once MicroStation and InRoads Survey opens. From the InRoads pull-down menu, select 
File > New.  The New dialog will appear.

3. Select the Survey Data tab.

4. Key in the Name: 12345SURVFieldbook01

5. Select the Apply button. The new fieldbook will appear below.

6. <D> the Close button.

7. From the Workspace bar the 12345SURVFieldbook01 should be active.

8. From the pull-down menu, select File > Import > Survey Data. The Import dialog will 
open.

9. Path to the Look in: C:\Projects\12345\ROW_Survey\Survey\Raw_Data
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10. Verify the Files of type: Sokkia SDR (*.sdr)

11. <D> the Options button.
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12. Select the Units tab.

13. Change the Linear Format Units: Meters

14. <D> the OK button.  The Survey Options dialog will close.

15. In the Import dialog select the data collector file you will be importing.

16. <D> the Import then Close buttons.

17. From the pull-down menu, select Survey > Fieldbook Data.  Take a minute to review 
the imported Survey control data that is now contained in the electronic Fieldbook.
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18. From the pull-down menu, select Tools > Survey Options the Survey Options dialog 
will appear.

19. Select the Units tab.

20. Change the Linear Format Units: US Feet

21. <D> the OK button.  The Survey Options dialog will close.

22. From the pull-down menu, select Survey > Fieldbook Data.  Take a minute to review 
the transformed Survey data that is now contained in the electronic Fieldbook.

Note: The file has now been converted to US Feet Units.

23. From the pull-down menu, select File > Save > Survey Data the Save As dialog will 
appear.

24. <D> the Save and Cancel buttons.  The Save As dialog will close.

Section Summary:
♦ In this lab an existing Metric fieldbook file was converted to US Feet units.
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Lab 9.11 - Exporting Survey Data to Sokkia SDR file

Exporting the fieldbook out to a SDR format would be required if you wanted to use the points 
and stake them out in the field.

Section Objectives:

♦ Create a Sokkia SDR file format file from the InRoads Survey fieldbook.

1. Verify the 12345SURV_Fieldbook fieldbook you want to export is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button.

2. From the pull-down menu, select File > Export > Survey Data.  The Export dialog will 
appear.

3. Change the directory to: 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books

4. Select the down arrow for Export as type: review the available file formats available.

5. Select from the list Export as type: Sokkia SDR33 (*.sdr)

6. Key-in the new file name 12345SURV_Fieldbook.sdr

7. <D> the Export button.  The Export dialog will close.

8. Open Windows Explorer Windows + E

9. Open and review the file in Notepad.
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\ 12345SURV_Fieldbook.sdr

Note: This file is ready to be uploaded into the data collector.  If you need to import this file 
back into InRoads Survey for any reason you will need to add survey header 
information into file.
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Section Summary:
♦ In this lab a Sokkia SDR file was created using the Export as type tool.
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Lab 9.12 - Exporting Survey Data using Text Export Wizard

Exporting the fieldbook out to another format would be required if you wanted to use the points 
and stake them out in the field.

Section Objectives:

♦ Create a customized exported ASCII file from the InRoads Survey Fieldbook using 
Text Export Wizard.

1. Verify the 12345SURV_Fieldbook fieldbook you want to export is active.  You can tell 
which fieldbook is active by the red box around the fieldbook button.

2. From the pull-down menu, select File > Export > Survey Data.  The Export dialog will 
appear.

3. Change the directory to: 
C:\Projects\12345\ROW_Survey\InRoads\Field_Books

4. Select the down arrow for Export as type: review the available file formats available.

5. Select from the list Export as type: Text File (*.*)

6. Key-in the new file name 12345SURV_Fieldbook.txt
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7. <D> the Export button.  The Export dialog will close and the 
Text Export Wizard dialog will appear.

8. <D> the radio button Comma

9. Key-in Number of Columns: 7

10. Key-in File Header: CDOT Survey Training “Initials” “Date”

11. Key-in File Tail: Exported Fieldbook 12345SURV_Fieldbook.fwd
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12. <D> the Next > button.  The final Step 2 of 2 dialog will appear.

13. <D> the header of the first column.  The column will highlight as shown below.

14. From the Data Type radio button select String: Export

15. In the Justification section of the dialog set the radio button to Left

16. <D> the second column header then select Point Name from the Data Type radio 
button.

♦ Justification: Left

17. Select the third column header then select Northing from the Data Type radio button.

♦ Justification: Left
♦ Precision: 2
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18. Select the fourth column header then select Easting from the 
Data Type radio button.

♦ Justification: Left
♦ Precision: 2

19. Select the fifth column header then select Elevation from the 
Data Type radio button.

♦ Justification: Left
♦ Precision: 4

20. Select the sixth column header then select Code from the 
Data Type radio button.

♦ Justification: Left

21. Select the seventh column header then select Description from the
 Data Type radio button.

♦ Justification: Left
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22. <D> the Save As button.  The Save As dialog will appear.

23. Key in File name: ASCII Export.tew

24. <D> the Save button.  The Save As dialog will close.

25. The Save Format to File Types dialog will appear.  Verify Format Name: ASCII Export

26. <D> the Yes button.  The Save Format to File Types dialog will close and the Step 2 of 2 
dialog will reappear.

27. In the Step 2 of 2 dialog <D> the Cancel button.  The Step 2 of 2 dialog will close.
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28. From the pull down menu select, File > Export > Survey Data

29. In the Export dialog change the Export as type: ASCII Export (*.txt)

30. Path to the directory: C:\Projects\12345\ROW_Survey\InRoads\Field_Books

31. File name 12345SURV_Fieldbook.txt

32. <D> the Export button.  The Export dialog will close.

33. Open Windows Explorer Windows + E

34.  Open and review the file created in Notepad.
C:\Projects\12345\ROW_Survey\InRoads\Field_Books\12345SURV_Fieldbook.txt



Colorado Department of Transportation   Page 231

A Practical Guide for Using InRoads XM LAB 9 - Additional Exercises

Section Summary:
♦ In this lab the Text Export Wizard was used to create a customized ASCII file from an 

open InRoads Survey Fieldbook.

Lab 9.13 - Exporting DC File from TGO

The workflows for exporting a DC file that will include the notes and attributes can be found on 
the CDOT CADD Library web page.
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Lab 9.14 - Merging InRoads Survey Fieldbook files

When a project is using more then one fieldbook for a particular job it is possible to merge 
those fieldbook files together.

Items to address prior to merging fieldbooks:

♦ There can not be duplicate point names between the fieldbooks.

♦ If you are using figure strings make sure they are not going to conflict with the figure 
strings in the other fieldbook.

Section Objectives:

♦ Merge two existing InRoads Survey Fieldbook files into one InRoads Survey 
Fieldbook file using the Import FWD tool.

1. Open a new working MicroStation model file.

2. Open an InRoads Survey Fieldbook.

3. From the InRoads pull down menu select File > Import > Survey Data The Import 
dialog will appear.

4. Select the Files of type: Field book (*.fwd)
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5. Select the fieldbook name you want to import.

6. <D> the Import then Close buttons.  The fieldbook files are now merged.

Section Summary:
♦ In this lab we merged two InRoad Survey Fieldbook files into one fieldbook file.
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